{ib}XML/CSS alternate stylesheets only giving blank page when :root inline

RESOLVED FIXED

Status

()

Core
CSS Parsing and Computation
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Jonathan Bartlett, Assigned: dbaron)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

When switching from the default stylesheet to the alternate stylesheet on XML
pages (using the xml-stylesheet processing instruction), the page goes blank
when the alternate stylesheet is selected.  This is not a stylesheet problem, as
the alternate one works when it is placed firts in the order. 

Reproducible: Always

Steps to Reproduce:
1. Go to
http://contributors.tgministries.org/current/ShortStudies/BeingPartOfTheBody.xml
2. Choose "View" -> "Use Style" -> "Normal"


Actual Results:  
Page becomes blank

Expected Results:  
Page should re-render with the new stylesheet

Comment 1

14 years ago
I see the bug on WinXP too, using Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.5b) Gecko/20030804

Comment 2

14 years ago
I see this also on LInux 2003080405

Comment 3

14 years ago
Confirming bug, 2003-08-01-05 trunk Linux.  
Also, if you change back to the initial stylesheet (that worked the first time)
the page it is still blank.

-> Style System
Assignee: other → dbaron
Status: UNCONFIRMED → NEW
Component: Layout → Style System
Ever confirmed: true
OS: Linux → All
The sheets both put blocks inside an inline root; we have some issues with
dynamic changes in those circumstances...
Summary: XML/CSS alternate stylesheets only giving blank page → {ib}XML/CSS alternate stylesheets only giving blank page
Whiteboard: DUPEME
(Reporter)

Comment 5

14 years ago
I modified the page to make the root a block, and the problem goes away.  I
don't know if this is a bug or not, then, as I'm not sure what CSS says about
whether or not the root element can be an inline element.
(Assignee)

Updated

14 years ago
Summary: {ib}XML/CSS alternate stylesheets only giving blank page → {ib}XML/CSS alternate stylesheets only giving blank page when root inline

Comment 6

14 years ago
Would this bug affect more than XML pages? Several people (including me) have
been seeing HTML pages missing the majority of their content (though the content
often shows up if the page is reloaded), and the latest hypothosis is that it is
related to the page having multiple alternate style sheets. The bug does not
appear to affect everyone, and it also appears to sporadically appear and
disappear. For instance, the mozilla-firebird pages have exhibited this problem
for me in the past (and quite consistently for a while), but recently they
started to render properly without fail. During this "OK" time a completely
different site (that used multiple alternate style sheets on the HTML) started
to render as consistently "empty", and then days later the problem is not
reproducable (and the CSS code did not change on this second site). Very weird.
Summary: {ib}XML/CSS alternate stylesheets only giving blank page when root inline → {ib}XML/CSS alternate stylesheets only giving blank page when :root inline
:root should never be able to become inline, btw
Depends on: 233480
(Assignee)

Comment 8

13 years ago
This works for me on a current build, even without the patch to bug 233480.
Created attachment 140931 [details]
Testcase showing the problem
That's because the page was changed to use display:block...... Attached testcase
shows the problem here.
(Assignee)

Comment 11

13 years ago
Fixed by checkin of bug 233480.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

3 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.