About box text is invisible when OS system colors set to white text

RESOLVED FIXED

Status

()

Firefox
General
--
minor
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Alexander O'Neill, Assigned: Arvid Axelsson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030804 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030804 Mozilla Firebird/0.6.1

The background color of the Firebird About box is hardcoded to white.  When
windows system colors specify white text, the text in the about box is invisible.

Specifying text colors in teh Firebird options does not affect text in the About
box.

Reproducible: Always

Steps to Reproduce:
1. Use the Windows display properties, go to 'Appearance' and choose the
'High-Contrast Black' theme.  Windows recommends restarting to fully switch
color schemes, but this usually isn't necessary in practice.
2. Start Firebird
3. Go to Help | About Mozilla Firebird

Actual Results:  
About box text shows up as white text on a white background, making it
impossible to read.

Expected Results:  
The About box should not hardcode a background color.  Either completely obey
the Windows system colors, the configured Firebird colors.  Alternatively,
hard-code text color as well, though this is not as good a solution.

Comment 1

14 years ago
Created attachment 129235 [details]
About popup with dark OS theme in Linux

Seems to be Windows-only; FB is obeying OS colours with GTK2 build in Linux.

Comment 2

14 years ago
Created attachment 129236 [details]
Default Qute theme this time - shows bug.

Silly me - I took that shot using the Pinball theme (which I maintain) which
does obey System Colours (sorry). The default theme does not, as this
screenshot shows.

Comment 3

14 years ago
Confirming, assigning to Arvid, taking QA, sorry for the bugspam :)
Assignee: blake → arvid
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: asa → davidpjames

Comment 4

14 years ago
Created attachment 129527 [details] [diff] [review]
Adds CSS color attribute where background-color is set.

Updated

14 years ago
Attachment #129527 - Flags: review?(noririty)

Comment 5

14 years ago
noririty - can you take a look at this? It's simple enough - we just force the
text colour to always be black and the background always be white on the about:
dialog. That's probably preferable to the other option, which is to have system
field colours for the background (as in my first screenshot above). Pinball will
now be using the scheme in the patch for that reason.
Summary: About box text is invisible when Windows system colors set to white text → About box text is invisible when OS system colors set to white text

Comment 6

14 years ago
Comment on attachment 129527 [details] [diff] [review]
Adds CSS color attribute where background-color is set.

r=me
Attachment #129527 - Flags: review?(noririty) → review+

Comment 7

14 years ago
There really shouldn't be any hard coded colour values in the browser at all,
they should all be system colours.  Maybe the scope of this bug should be
changed, or a new one filed?

Comment 8

14 years ago
Michael, did you have a look at the dialog? The reason for the fixed background
colours is so that it matches an image. The inner box (the UA string box) could
in theory be done using system colours (for background and forground) but would
look completely out of place in most colours schemes because it would still be
atop the fixed background colour.

Just my thoughts on it (and wasn't this checked in at 08/25/2003 09:41?).

Comment 9

14 years ago
Yes, this was checked in

-->Fixed
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.