Closed Bug 215139 Opened 18 years ago Closed 9 years ago

Ability to type the name of the bookmark in address field

Categories

(SeaMonkey :: Bookmarks & History, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: joeclark, Unassigned)

Details

(Whiteboard: [2012 Fall Equinox])

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030624

Mozilla makes it punishingly difficult to type boomarked pages into the address
bar. You have to type the *domain name* (Ws not required) to match a bookmarked
entry. IE 5 on Macintosh understands that real people do not file bookmarks by
URL-- mentally or in software-- and permits you to type the *name* you assigned
to the bookmark. 

Example: http://diveintomark.org
I *must* start typing _div_ into Mozilla to match it. If I name the bookmark
Pilgrim or Mark Pilgrim, I cannot type _mar_ or _pil_ as I can in IE 5.

Mozilla's current function is suitable for geeks who could type out the full URL
of every site they've ever visited anyway, but is unusable for real people.

Reproducible: Always

Steps to Reproduce:
1. go to a site (easiest if site name differs from URL)
2. bookmark the site with a name different from URL
3. open new window
4. in address field, attempt to type the *name* you just assigned

Actual Results:  
No match.

Expected Results:  
Match the name, URL, or both. In fact, it should search on every aspect of
bookmarks.

Mac IE 5 does this perfectly.
This would just be a variation of the existing Custom Keywords function, only
keyed to the bookmark name instead of the assigned keyword.
http://www.mozilla.org/docs/end-user/keywords.html
This is a RFE (Request For Enhancement).

I see no reason we should do this - this is *not* what bookmarks are for - this
is the area of bookmark keywords.
Severity: normal → enhancement
Responding to 2 from James:

<ul>
<li>It's a useful UI feature already implemented in a competing browser that has
no effect on W3C or other standards compliance.</.i>
<li>The name of a bookmark is self-evidently not a keyword any more than the
Library of Congress subject categorization of a book is equivalent to the book's
title.</li>
<li>Users should not have to laboriously search keywords for the title they
themselves assigned to their own bookmarks. We have computers to do that sort of
thing for us, and on IE 5 Macintosh, it already does.</li>
</ul>
Bookmark keywords aren't the same, I know, they are best used for searching. But
there is a bookmarks menu for the bookmarks. If you want quick access to
bookmarks, use the Personal Toolbar Folder.

I my opinion, we've got enough things going on in the URL bar as it is, and I'm
not sure how many people would even think about starting to type a bookmark name
in the box (feel free to prove me wrong here).

I'm not going to say we can't implement this, but I don't think it would be
worthwhile putting in the effort for the changes needed, is all (why I'm leaving
the bug open, but unconfirmed).

Changing summary to reflect RFE status.
Summary: Cannot type the name of the bookmark (only its address) in address field → Ability to type the name of the bookmark in address field
The other UI functions in the address bar do not impinge on the one I'm looking
for. You don't have to know about those. They don't crowd out this function.

Personal Toolbar Folder? You're kidding, right? I can type two or three
characters in IE 5 to match any bookmark at any level, wherease with the
Personal Toolbar Folder, which I already use, I must type the exact domain name
or use the mouse.

IE 5 Mac users already have this feature and already use it, so there's your
user base right there. It was never a hypothesis of mine; I use it myself, as
have other IE 5 owners. It's also an obvious thing for anyone to try-- just type
away in the address bar, and when it doesn't work in Mozilla as it obviously
should, get frustrated.
I should point out two things here:

1. Currently, not even custom keywords set on bookmarks work to autocomplete as
you type them in.  If I have a bookmark XYZ on which I've defined a custom
keyword of "foobar" - when I type "foo" into the location bar, it does NOT
automatically suggest "foobar" as what I'd like.  So comparing this to custom
keywords is fine - except for the fact that an enhancement request would then
have to be filed against those.

2. Given the above, I think it would make more sense to have only custom
keywords auto-complete BUT have a custom keyword of the bookmark name
automatically set if you don't override it.  For example, if I create a bookmark
named XYZ, and leave the custom keyword empty, then Mozilla would automatically
give it a custom keyword of XYZ.  That way, it has the "effective" result of
auto-completing when you type in the name of a bookmark - by virtue of the fact
that it's the same as the custom keyword that's been automatically assigned. 
(Plus, it also reduces the number of different things to check.)

Lastly, if it's not already implemented, and implementing it won't interfere
with something already in place (and it doesn't introduce any unwarranted
overhead in location bar entry processing) then I see now reason why it should
not be considered.  (So long as somebody is willing to work on it.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Joe, the PTF comment is mearly one of speed - it's much easier to use the PTF
than to try to remember somethings domain usually. And even if I can, it's
usually still quicker to click once or twice than to bother typing it and
'navigating' the auto-complete list.

And you still haven't shown that people would use it, only that people have it
aailable in some cases. Since only URLs appear in the URL bar, I find it odd to
think I could type a bookmark name into it.

And then there's is the problem of collisions with bookmark keywords. If the
first word (i.e. everything before the first space, if there is one) matches a
bookmark keyword, then it's matched to that. What should happen if the first
word of the bookmark I want happens to be a bookmark keyword? Should it do an
exact bookmark name match first, then check for keywords?
> Since only URLs appear in the URL bar, I find it odd to
> think I could type a bookmark name into it.

Keywords already appear in the location bar, and nobody thinks that's odd.  This
is no different.

> And then there's is the problem of collisions with bookmark keywords.

Not if, as per my comment 6, only keywords are used but are automatically
assigned to the bookmark name if not user-specified.  Also, that aside, we
already DO have to deal with collisions between domain names and keywords.  If I
have a bookmark with the keyword "microsoft", and I type just that into the
location bar - what happens?  Obviously there's a "collision" (as you say)
between the domain name and the keyword.  The answer is that the keyword is
used.  All this means is that priorities need to be set.  I would say, in this
order of priority, search for keywords, bookmark names, then do a domain lookup.
Product: Browser → Seamonkey
Reassigning as per Bug #32644
Assignee: p_ch → nobody
WFM here, added bookmark with name different from it's URL, start typing it's name and it's appeared in suggestion list
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.