Backspace Makes Further Input Impossible In Composition (focus loss)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: mozilla, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
2003080404 trunk

Step to Reproduce:

1. Open a mail/news compose window.
2. Fill in an address in the "To:" field AND press ENTER. You should have a 
   blinking cursor on a new "To:" line.
3. Press the backspace key until the second "To:" line disappears.

Result:
Cursor disappears and you can no longer input text in the To: area *OR* the
Subject area. You can work around this by clicking in the body area and then
back into the "To:" or Subject fields.

Expected:
Cursor should have returned to the previous "To:" line.

Comment 1

15 years ago
Did bug 170292 get fixed?  BS _should_ _not_ move the cursor to the previous
field. Did you try shift-tab to get back to the first To: field?
(Reporter)

Comment 2

15 years ago
It doesn't matter how you try to get to the other fields. If you do not go to
the body field first you will never be able to input anymore. You can try using
tab, the mouse, anything.
(Reporter)

Comment 3

15 years ago
Also being seen in Thunderbird. See Scott McGregor's comments in "Known Issues"
#2: http://forums.mozillazine.org/viewtopic.php?p=143826
Summary: Backspace Makes Further Input Impossible → Backspace Makes Further Input Impossible In Composition

Comment 4

15 years ago
*** Bug 218964 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
Note in bug 218964 that impossible is not true, just tough for Joe Average to
figure out how to do.

See also bug 217390, which involves focus loss without keyboard input.
Summary: Backspace Makes Further Input Impossible In Composition → Backspace Makes Further Input Impossible In Composition (focus loss)

Comment 6

15 years ago
this is a dupe of a bug that has already been fixed in thunderbird and in
mozilla mail. I'd suggest using a newer build. 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.