Browser quits immediately if flash or java are used, (if installed)

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED WORKSFORME
15 years ago
2 years ago

People

(Reporter: Desmond Armstrong, Assigned: Peter Lubczynski)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3.1) Gecko/20030428
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3.1) Gecko/20030428

After installing the plugin for flashplayer the browser quits on entry to above
sites. O.K. on www.bbc.co.uk (but I guess flash not used there).
Deleted flash components from /usr/lib/mozilla-1.3.1/plugins and the problem was
cleared but now we can't use flash!

Reproducible: Always

Steps to Reproduce:
1. Install flash plugin.
2. Browse to sites www.ecs.uk.com or www.ecsusa.com
3. Browser quits on entering site
4. Delete flash components from /usr/lib/mozilla-1.3.1/plugins
5. Now browser works again even on above sites.

Actual Results:  
Mozilla quits without any comment.

Expected Results:  
Did not expect browser to quit. It should work

My version of Mandrake9.1 is fully updated.

Comment 1

15 years ago
try 1.5a or a trunk build (or at least 1.4).  1.3(.1) is too old to report bugs.

==> plugins
Assignee: general → peterlubczynski-bugs
Component: Browser-General → Plug-ins
Keywords: crash
QA Contact: general → bmartin

Comment 2

15 years ago
*** Bug 215376 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

15 years ago
I have done more testing on the problem of flash plugin.
I now find that the latest netscape (7.1) also quits on the websites defined.
I have now managed to install the java pluin x-java-vm only to find that on the
website news.bbc.co.uk that this causes the browser to quit (1.4 and 1.5a).
Having struggled to install the java and finding the problem similar to the
problem already reported, I realize that the problem may be deeper within the
Mandrake 9.1 which is fully updated from the Mandrake errata mirror. Again I
have confirmed by removing the java symbolic link.

Now I am wondering if I could have something wrong in my installation, perhaps
there is a wrongly set priviledge somewhere.

I will follow up any suggestion offered.

Further comment the windows version of Mozilla is working fine on the win98se
platform with flash player.

Comment 4

15 years ago
It seems Mandrake has some problems as we get pretty high amount of problem
reports regarding Mandrake (9.0 and 9.1) with Java and Flash installed on our
forums. 

Browser either crashes on it's own or crashes whole X server when accessing
webpages with Java/Flash content, problems specific for Mandrake only.  

Comment 5

15 years ago
Desmond, can you please post what security level do you have in your Mandrake
installation and retest newest Mozilla nightly/release?

Our users mostly report problems with highest security level (probably some
permission problem then).
(Reporter)

Comment 6

15 years ago
Have downloaded and installed latest nightly mozilla on 12 August and confirmed
problem still exists with flashplayer (not yet checked with the java).
Please advise how I can retrieve a log on my machine for this problem.
Summary: After installing the flashplayer plugin browser quits as soFlash Plugin causes browser to quit on above sites. → Browser quits immediately if flash or java are used, (if installed)
(Reporter)

Comment 7

15 years ago
Further comment, when the browser quits because of plugin, the url is not
remembered in the recent list.

Comment 8

15 years ago
what version of flash are you using?  6.0v79 is the latest
(Reporter)

Comment 9

15 years ago
The version of flash used is 6.0r79 (4 March 2003).
---www.ecs.uk.com and www.ecsusa.com use flash
---news.bbc.co.uk uses java
If the required plugin is installed then immediate quit on entry to the site,
otherwise message to ask about downloading required plugin. As the plugin can be
disabled in mozilla we can continue to work, but I do not know how to disable
flash in netscape 7.1 which also quits in the same way. I acknowledge that this
may be a problem specific to mandrake so, I await anxiously, a patch, or other
solution.
Problem is totally repeatable on my machine.

Comment 10

15 years ago
I run on redhat9.0 ,mozilla1.4,flashplayer6.0,java1.4.2 found the same problem
mozilla1.2.1 with flashplayer6.0 play flash ok
mozilla1.4 with flashplayer4.0 is ok

Comment 11

14 years ago
I am running Mandrake 8 on a laptop and on a desktop with an updated kernel
(2.4.20ac2). The desktop has no problems with flash (6.0.79) but the laptop's
Netscape 7.1 quits abruptly whenever I load a flash page. I have tried
reinstalling the libstdc++ recommended by the Mozilla plugin team, and
reinstalling ttfonts, freetext, urw-fonts, etc. Would you expect the crashing if
I have a problem with these libs or fonts, or do I need to be looking for
another difference between my laptop's Mandrake install and the desktop's
installation?

Comment 12

14 years ago
I resolved my flash crashing under Mandrake, by an entry changing the X config
file (for me, /etc/X11/XF86Config-4).

In the first screen section, Mandrake had set the depth to 15:
  DefaultColorDepth 15
I changed it to
  DefaultColorDepth 16

and Flash now works for me. I removed all plugins, including Java, a long time
ago when trying to troubleshoot my flash problems, so I am not sure if I had a
problem with Java, or if Java would work now.

I hope this helps someone else...
Greg

Comment 13

14 years ago
> In the first screen section, Mandrake had set the depth to 15:

that's bug 200829

Comment 14

14 years ago
Thanks Andrew... I've searched on Flash Crash lots of times, and never noticed
bug 200829 until today. I never thought the problem had to do with the X
configuration. The Macromedia Linux-flash readme file says "Flash Player should
work with any X server configuration. However, optimal performance is achieved
at the following color depths and color mask settings:". Then they list a depth
15 underneath:

Depth: 15
   Bits Per Pixel: 16
   Visual: TrueColor
   Red Mask: 0x00007C00
   Green Mask: 0x000003E0
   Blue Mask: 0x0000001F

Mandrake doesn't give you a UI with "bits per pixel", and the XFree86 version it
installed doesn't show any option like "bits per pixel" in the man page, so I
didn't bother to mess with this, until I got desperate last night. And even then
I tried things like Option "NoAccel" first.

I wonder how many of the 37 or so bugzilla reported flash crashes might be
because of a depth of 15, or, more probably, an non-byte-bounded bits per pixel
size?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 16

13 years ago
Linux:

I did work on this a long time ago. the problem was solved using the latest
Flash 7 which works down to 8 bits colour depth.
On java it is important to remember to uninstall the old one first. Then check
operation BEFORE adding the java link. If the link is in twice the browser will
crash.
Best use latest version of browser and plug-ins.
Also for real player uninstall old one first.
The plug-ins java, flash and realplayer work reliably for me on many machines.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 17

13 years ago
We don't know what fixed this worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 18

13 years ago
I have checked the sites www.ecs.uk.com and www.ecsusa.com and they work
perfectly with my setup. Yes I do have recent versions of all modules. Both
Firefox and Mozilla do work fine on those sites.
For your information www.macromedia.com uses Flash but not Java. You should use
this site to positively identify your problem Flash, Java or both.
You must update Flash to Flash 7 as a first.

System:
Mandriva 10.1 Official, fully updated.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050416

Plugins:
Helix DNA Plugin: RealPlayer G2 Plug-In Compatible version 0.4.0.552 built with
gcc 3.2.0 on May 13 2005
    File name: libjavaplugin_oji.so
    Java(TM) Plug-in 1.4.2_05

File name: nppdf.so

    File name: libflashplayer.so
    Shockwave Flash 7.0 r25

I too had problems with the ECS websites originally, (I use their M/Bs) and my
problem was colour depth when Flash required minimum 16 bits and my on-board
video would not support it. Flash 7 resolved this problem in that it supports
colour depth down to 8 bits.

I also had problems with Java. I would install that and found that I had failed
to properly uninstall previous version. It is very important to properly
uninstall previous version of Java.

Now, you must update to Flash 7 as a first.
Please use Flash 7 and then report, also please advise the colour depth of your
video.

I predict, next April, many will be throwing out their Computers saying "I never
want to see a computer again in my life".
It is up to us to publicise the use of Linux as a reliable system for all to use.
My main activity, at present, is repairing computers and dual booting and
encouraging users away from that system which is open BY DESIGN, for good
historical reasons, for viruses etc.
Kind Regards.

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: bmartin → adobe-flash
Target Milestone: --- → 2004
Version: Trunk → 6.x

Comment 19

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: 2004 → ---
Version: 6.x → unspecified
You need to log in before you can comment on or make changes to this bug.