cursor appears above textarea instead of inside it

RESOLVED DUPLICATE of bug 214607

Status

()

Core
Layout: Form Controls
--
minor
RESOLVED DUPLICATE of bug 214607
15 years ago
15 years ago

People

(Reporter: Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com], Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030721 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030721 Mozilla Firebird/0.6

Version:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030721 Mozilla
Firebird/0.6

That version works correctly.  When I click the textarea, the cursor is
positioned at the very beginning of it.  However, the 7/24 nightly displays
incorrect behavior.  When I click the textarea, the cursor is about 1 line above
the textarea, instead of inside it.

I will provide the version string for the 7/24 build shortly.

Reproducible: Always

Steps to Reproduce:
1.  Go to URL provided
2.  Click the textarea
3.  Observe cursor position

Actual Results:  
Cursor is one line above textarea until I begin to type.

Expected Results:  
Put the cursor somewhere within the textarea.
Correction, 7/23 shows the incorrect behavior:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030723 Mozilla
Firebird/0.6

8/02 also shows the incorrect behavior.

Comment 2

15 years ago
I see this to on LInux 2003080405
I think this is a dupe.

Comment 3

15 years ago
Verified in linux, trunk from august 3.

Interesting inconsistencies...
Compare:
data:text/html,%3Cbr%3E%3Ctextarea%20rows%3D%225%22%20cols%3D%2225%22%3E%3C%2Ftextarea%3E
with:
data:text/html,%20%3Cbr%3E%3Ctextarea%20rows%3D%225%22%20cols%3D%2225%22%3E%3C%2Ftextarea%3E

The first one exhibits this behavior, while the second one does not. The two
URIs are identical except that the second one contains whitespace before the br.

Updating the URL to this simplified testcase (taken from a minimized testcase
Chris put up at his website), confirming, and updating OS to all. A mac person
can update the platform if they witness it. Adding regression keyword.
Severity: trivial → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All

Comment 4

15 years ago
Very possibly a dupe of bug 214607, but I haven't looked closely enough to dupe
it with confidence.
Marking as dupe of bug #214607, because the testcase in the second comment in
that bug shows the same behavior.

*** This bug has been marked as a duplicate of 214607 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.