If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When dragging links, the Close Tab icon should change to a New Tab icon

RESOLVED INVALID

Status

()

Firefox
Toolbars and Customization
RESOLVED INVALID
14 years ago
6 years ago

People

(Reporter: Prognathous, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

Firebird's Close Tab widget also serves as a drop target for links. This is
especially important when several tabs are open and no space is left for the
drop target (I will soon attach a screenshot that shows this problem).

Rational:
1. Dropping links on the tab bar (to open new tabs) is one of four supported
ways to open a link in a new tab.
2. During this drag&drop operation, the *only* functionality of the Close Tab
widget is to provide a drop target for new tabs. It can't be used for closing
tabs while a link is being dragged.
3. Using a Close Tab icon |X| as a drop target is counter-intuitive. The icon
hints for closing an object, not for spawning one.

See the OS X Trash as a good example of a widget that changes its icon to
reflect a different action during a drag. When the user drags a folder or a
file, it looks (and acts) as a Trash bin; when the user drags a mounted disk/CD,
it looks (and acts) as an eject button.

Prog.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 129278 [details]
Dragging a link onto the Close Tab icon

Note that this is the only free space in the tab bar for dropping links. To the
left of it, there are existing tabs which will lose their current content if
the user drops the link on them.

Prog.

Comment 2

14 years ago
Good idea, marking NEW for developer review
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago
I think this is a stupid idea
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

14 years ago
Lil46john@aol.com wrote:

> I think this is a stupid idea

And your rational is? shouldn't there be some reasoning behind closing bugs as
WONTFIX, besides calling members stupid?

Prog.
(Reporter)

Comment 5

14 years ago
CCing Lil46john@aol.com, since he is the one who closed this bug.

Prog.

Comment 6

14 years ago
Pham, it's not up to you to decide what's good and what's bad here. Calling
other ideas stupid is bad manners. Reopening. Don't mess with this bug again!
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 7

14 years ago
This is not a good idea, especially since few use drag link to tab bar and have
enough tabs to make this useful.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

14 years ago
First:

(Simon 'sipaq' Paquet, In reply to comment #6)
> Pham, it's not up to you to decide what's good and what's bad here. Calling
> other ideas stupid is bad manners. Reopening. *Don't mess with this bug again!*

And then:

(Pham, In reply to comment #7)
> This is not a good idea, especially since few use drag link to tab bar and have
> enough tabs to make this useful.

Simon, please re-open this bug and check how on earth Pham got editbugs.

BZ, just thought this would interest you, given your little "discussion" with
Pham in bug 200826.

Timeless, well, yes I know you have no role in Firefox, but then again... I know
you've had your say about the subject of overzealous bugzilla participants and
BugDay causalities.

Prog.
I have no idea who Pham is; maybe he's empowered to WONTFIX Firefox bugs....
CCing asa, in any case.
Pham, you're not in any position to WONTFIX bugs, especially ones that could be
a useful feature.  This was already reopened once by Simon, and your continued
abuse of the permissions granted in Bugzilla (and this isn't the first time
you've done something like this) leads me to believe your permissions should be
revoked since you don't want to pay attention to the required etiquette.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
>your continued abuse of the permissions granted in Bugzilla (and this isn't the
>first time you've done something like this) leads me to believe your
permissions >should be revoked since you don't want to pay attention to the
required etiquette

Done.

Updated

12 years ago
Assignee: hyatt → nobody
Status: REOPENED → NEW
QA Contact: bugzilla → toolbars

Comment 12

10 years ago
Despite its checkered history, I'm going to take the risk and mark this bug as INVALID now, since it relies on the general close tabs button, which disappeared years ago. If it's buried somewhere as a hidden pref still, feel free to reopen if you like. See bug 320638 for a new way to load links in new tabs, anyway.
Status: NEW → RESOLVED
Last Resolved: 14 years ago10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.