[PP] Font mapping is wrong

VERIFIED FIXED in M2

Status

Core Graveyard
GFX
P1
normal
VERIFIED FIXED
20 years ago
9 years ago

People

(Reporter: Steve Dagley, Assigned: davidm)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

Updated

20 years ago
Status: NEW → ASSIGNED

Description

20 years ago
To reproduce, open test0.html with Viewer and Communicator: look at the line
"This is a paragraph with font variations: Bold Arial, Italic Verdana, COURIER,
Times New Roman.". The fonts are not the same in the 2 windows.

Comment 1

20 years ago
Another instance of the problem: go to "aol.com" -> all the 'bullet' characters
are replaced with 'sygmas'.

Updated

20 years ago
Assignee: pierre → davidm
Status: ASSIGNED → NEW

Comment 2

20 years ago
Reassigned to <davidm>
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

20 years ago
Fix checked in. There are still a couple of problems. First if you are using
ATSUI the spacing is all messed up since we are not measuring text properly.
Second if you are rendering without ATSUI you will get summation characters since
we are not doing a conversion between Latin-1 and MacRoman.
(Assignee)

Comment 4

20 years ago
*** Bug 2154 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Status: RESOLVED → REOPENED

Comment 5

20 years ago
Re-opening as a courtesy, per 1.13.98 Mac OS build.

While the bug does appear mostly fixed, "Italic Verdana" is not drawn in italics
by Viewer or apprunner, whereas it is drawn in italics by Communicator 4.5.

However, this is also the case on Win32 Viewer (1.12.98 build). Is this a known
issue, or should I split out a bug report? (and if so, to whom?)

Thanks!
(Assignee)

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
(Assignee)

Comment 6

20 years ago
I filed a bug against the parser ( rickg? ). If you look at the html you will see
that there is a <font face > tag right before the Verdana font face tag which is
lacking a </font> closing tag. If you either a) add the </font> tag or b) remove
the meaningless <font face> you get italics.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 7

20 years ago
Verified fixed, then. ;) Thanks, David!

Comment 8

20 years ago
Inserting Milestone info.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.