Thunderbird/Moz not sending password for smtp auth correctly.

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: bcook, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Using mail client that comes w/ Moz 1.4 doesn't send password string to qmail
server w/ smtp-auth patch.  Outlook 2000, 2002/XP, Outlook Express 5.x 6.x does.
 I'm sure I can't be the only person having this problem, but I see no one else
having it, yet I can reproduce it on all my boxes.

This was working and now has stopped, it looks like it's sending the message
header rather than a password.  This is smtp-auth with tls encryption.

Reproducible: Always

Steps to Reproduce:
1. setup an account w/ bsdwebsolutions.com (I own the isp)
2. setup your mail account to use smtp auth (for relaying) w/ or w/o TLS
3. contact bcook@bsdwebsolutions.com for an account to test.

Actual Results:  
Aug  6 13:19:17 sodium vpopmail[10922]: vchkpw-smtp: password fail (pass:
'<10921.1060190357@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 13:20:14 sodium vpopmail[10955]: vchkpw-smtp: password fail (pass:
'<10954.1060190414@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 13:21:18 sodium vpopmail[10960]: vchkpw-smtp: password fail (pass:
'<10959.1060190478@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 13:22:02 sodium vpopmail[10962]: vchkpw-smtp: password fail (pass:
'<10961.1060190522@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 13:23:02 sodium vpopmail[10970]: vchkpw-smtp: password fail (pass:
'<10969.1060190581@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 13:34:44 sodium vpopmail[11076]: vchkpw-smtp: password fail (pass:
'<11075.1060191284@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 13:36:39 sodium vpopmail[11129]: vchkpw-smtp: password fail (pass:
'<11128.1060191399@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 13:56:43 sodium vpopmail[11657]: vchkpw-smtp: password fail (pass:
'<11639.1060192603@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 13:59:10 sodium vpopmail[11807]: vchkpw-smtp: password fail (pass:
'<11799.1060192750@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 14:03:13 sodium vpopmail[12076]: vchkpw-smtp: password fail (pass:
'<12069.1060192992@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 14:03:33 sodium vpopmail[12098]: vchkpw-smtp: password fail (pass:
'<12096.1060193013@mail.bsdwebsolutions.com>')
bcook@bsdwebsolutions.com:24.97.125.70
Aug  6 14:06:26 sodium vpopmail[12313]: vchkpw-smtp: system password fail (pass:
'passwordhere') usernamehere:24.97.125.70

The last is an when I put the username and password in 'wrong' on an outlook
2002 account.  Just to see if what I was looking at was correct.

Expected Results:  
from unknown (HELO poklib.org) (bcook@bsdwebsolutions.com@24.97.125.70)  by
mail.bsdwebsolutions.com with AES256-SHA encrypted SMTP; 4 Aug 2003 16:59:51 -0000

This shows what it used to look like.

from unknown (HELO mystique2k) (bcook@bsdwebsolutions.com@24.97.125.70)  by
mail.bsdwebsolutions.com with RC4-MD5 encrypted SMTP; 6 Aug 2003 18:25:26 -0000

This is what it looks like from Outlook 2002/XP.

Like I said it used to work, I have been making adjustments to my smtp servers
lately and I think that somewhere along the way, something got corrupted w/ Moz.
 Since all the Moz/Thunderbird apps (look like) they share mail data.. it would
hold that something isn't being read correctly.

Clues or idea's would be appreciated.

I thank you for taking the time to read this message.

Comment 1

16 years ago
It looks like there is generally trouble with SMTP authentication. I'm having
trouble connecting to any SMTP servers too, and there seem to be several similar
tickets for this type of problem. I'm running 1.4, but it also affects me with
thunderbird-0.2_alpha20030813.

Comment 2

15 years ago
My mail provider also uses qmail for our mail server and I cannot authenticate
correctly to send mail.  Seems that our problems are similar and haven't been
fixed yet as of my version 0.4a
Brian, Marc, Jon, protocol log is usullay needed for problem determination of
server/client communication problem.
Your SMTP protocol log will help developers ( See
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#pop )
Do not forget to change NSPR_LOG_MODULES=IMAP:5 to "SMTP:5" for SMTP log. 

Your SMTP server setting information will also be required since Mailers's
action depends on user's settings.
Go Account Manager/Outgoing Server(SMTP), click Advanced button, choose SMTP
server, click "Edit" and let developers to know your settings.
Hmm, I'm seeing a related problem. 
Every time I want to send an Email (SMTP to Exchange server) I get prompted for
the password *multiple times*. Even if I check "remember password" in the
password popup box. The magic number of times seems to be "4", since usually on
the 4th try  the Email gets sent. I'm using Thunderbird and can reproduce this
on 0.4 "GA". I captured an SMTP log I'll be attaching, just in case it helps.
Created attachment 137831 [details]
SMTP log of failed attempts to log in to send Email

This is the SMTP log I captured at log level SMTP:9. Enjoy.

"Help us, Obi-Wan Kenobi. You're our only hope."
Christian J. Callsen, your SMTP protocol log says :
  
> SMTP Connecting to: ppp.qqq.com
>
> SMTP Response: 220 ppp.qqq.com ESMTP Server
> (Microsoft Exchange Internet Mail Service aaa.bbb.ccc.ddd) ready
>
> SMTP Send: EHLO ppp.qqq.com
>
> SMTP Response: 250-ppp.qqq.com Hello [CCALLSEN2]
> SMTP Response: 250-XEXCH50    > SMTP Response: 250-HELP
> SMTP Response: 250-ETRN       > SMTP Response: 250-DSN
> SMTP Response: 250-SIZE 0     > SMTP Response: 250-AUTH LOGIN
> SMTP Response: 250 AUTH=LOGIN

> SMTP Send: AUTH LOGIN
>
> SMTP Response: 334 VXNlcm5hbWU6   > SMTP Response: 334 UGFzc3dvcmQ6
> SMTP Response: 535 LOGIN authentication failed
>
> SMTP Send: AUTH LOGIN
>
> SMTP Response: 334 VXNlcm5hbWU6   > SMTP Response: 334 UGFzc3dvcmQ6
> SMTP Response: 535 LOGIN authentication failed
>
> SMTP Send: AUTH LOGIN
>
> SMTP Response: 334 VXNlcm5hbWU6  > SMTP Response: 334 UGFzc3dvcmQ6
> SMTP Response: 235 LOGIN authentication successful
>
> SMTP Send: MAIL FROM:<xxx.yyy@zzz.com> SIZE=1636
>
> (Mail sending flow is omitted by me)

"AUTH LOGIN" failed two times but third "AUTH LOGIN" was successufull.
This is normal flow, or usual fallback due to :
 inappropriate settings of "Use Secure Connection:",
 or a kind of mismatch between server side settings(or expectation)
    and client side settings(or expectation),
 or inappropriate server side setups.

Mozilla/Thunderbird had problem of "Forgetting(clearing) password on prompt" but
I heard  this was resolved some weeks or a few months ago.
But some "Many time password prompting" problems are found in Bugzilla lately. 

Christian,
(Q1) You had to type password on prompt?
     Or password was pre-filled and you didn't need to fill it again?
(Q2) What is your "Use secure connection:" setting of SMTP server settings?
     Go "Outgoing Server(SMTP)" and click "Advanced" button and "Edit".
(Q3) Does problem still occur on latest nightly build?
Wada-san:

(Q1) You had to type password on prompt?
     Or password was pre-filled and you didn't need to fill it again?

(A1) No, had to re-type every time. Even if I check the "remember password" box.

(Q2) What is your "Use secure connection:" setting of SMTP server settings?
     Go "Outgoing Server(SMTP)" and click "Advanced" button and "Edit".

(A2) I tried changing it but reverted back to "none" (i.e., "No" on "use secure
connection).

(Q3) Does problem still occur on latest nightly build?

(A3) TBird build 0.5a 20031219 seems to exhibit this also.

I think "But some "Many time password prompting" problems are found in Bugzilla
lately." is a good description for the problem, but I couldn't locate any of
those bugs. You can consider this a duplicate report, then.

I should also mention that this is SMTP only. The IMAP connection never asks for
the password more than once. And it's still happening, both 0.4 and subsequent
nightlies.
(Q1) What password manager entriy is defined for the SMTP server?
My password manager has only one entry becasue SMTP AUTH is used in only one
SMTP server.
> Site=smtp://<username>@<smtp_hostname> Username=<>
Check also whether This SMTP server is regstrated as "Password Never Saved" site
or not.

(Q2) Does problem occur on newest build too?
My SMTP server returns next data to EHLO.
> 250-AUTH CRAM-MD5 PLAIN LOGIN
I experienced login retry loop(when correct password is already saved) or
forever password prompt(after password entry is deleted) when I changed "TLS if
avail" to "NO" in December.
("NO" is sufficient but I set "TLS if avail" for test in the past, and forgot to
change it back.)
But no problem occured on 2003010308-trunk/Win-Me, with both "NO" and "TLS if
avail".
Correction. Sorry for spam.
200*4*010308-trunk instead of 200*3*010308.
Wada-san,

A1. I can confirm that a remembered password shows up in the password manager in
the appropriate way (your Q1).

A2. Haven't tried a newer build than 20031219 yet, but will do.
Yeah, still happens on the build from 20040105. I'll collect a new SMTP log file.
Created attachment 138529 [details]
SMTP log of 2 attempts to send email with failed logins

I sent 2 emails where the SMTP password was requested several times (5 times,
the first go). Each time I entered the password *and* checked "remember
password" in the password dialog. After sending the Email the password manager
has an entry for the password. This is very reproducible. I've configured NO
SSL/TLS/??? - just plain connection to port 25. I'm talking to an MS Exchange
server using SMTP.
This is with TBird 0.5a 20040105, Windows 2000 SP3.
Here is an extract from my prefs.js file (all lines that have smtp in them):

user_pref("mail.identity.id1.smtpServer", "smtp1");
user_pref("mail.smtp.defaultserver", "smtp1");
user_pref("mail.smtpserver.smtp1.auth_method", 1);
user_pref("mail.smtpserver.smtp1.hostname", "exwest2.webmethods.com");
user_pref("mail.smtpserver.smtp1.port", 25);
user_pref("mail.smtpserver.smtp1.try_ssl", 0);
user_pref("mail.smtpserver.smtp1.username", "chris");
user_pref("mail.smtpservers", "smtp1");
Is there anything I can do to get this bug into the CONFIRMED state?
Your case seems to be different from reporter's case.

(Reporter's case)
> mail.bsdwebsolutions.com with AES256-SHA encrypted SMTP
> mail.bsdwebsolutions.com with RC4-MD5 encrypted SMTP
In reporter's case, password was prompted forever and seems to be encripted
password problem in authentication.
(My old loop case, 250-AUTH CRAM-MD5 PLAIN LOGIN, also relates to CRAM-MD5, and
is already resolved.)
(And because no protocol log is available yet, problem seems to disappear with 
newer builds.)

(Your case)
> SMTP Response: 250-AUTH LOGIN
> SMTP Response: 250 AUTH=LOGIN
In your case, authentication fails several times but falls back successfully.
Two or three times failure seems to be caused by password attempt with
encryption although your server says no encription is supported - opposite to
reporter's one.
This is probably regression by encripted authentication support for SMTP because
 your problem occurs even on newest build.

Christian J. Callsen, I recommend you to open separate bug with more appropriate
summary and your prefs.js data and protocol log for ease of problem analysis by
developers.
Problem of Christian J. Callsen, which was started by Comment #4 and ended by
Comment #16, was processed by Bug 230766 and was closed as WORKSFORME some days ago.

bcook@bsdwebsolutions.com (Brian) the bug opener, Marc Doughty and Jon Wicks,
does problem still exist?

Comment 18

15 years ago
Brian, Marc, Jon: Are you all still seeing this bug in recent builds?
Product: MailNews → Core
no response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.