A part of the view is shifted 1px to the left when unselecting text

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: Gtk
--
minor
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: mats, Assigned: blizzard)

Tracking

({pp, regression, testcase})

Trunk
x86
Linux
pp, regression, testcase

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/01, URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
A part of the view is shifted 1px to the left when unselected leaving parts
of letters missing.  See for example the word "body" in the last line of the
indicated paragraph in the screenshot.  The vertical line is missing from
the "d" making it look like a "c".  Follow this line upward and you see there
is a pixel missing from each text line in the indicated area.

REPEAT BY:
1. go to http://www.livejournal.com/users/jwz/239101.html
2. select/unselect text by clicking on the name "Lee Chin" and dragging down
   with the mouse button pressed - drag past the image and then up again,
   unselecting the text.
3. if it doesn't occur the first time, try resizing the window slightly or try
   it when the vertical scrollbar is present/not present.

After a few tries it is 100% reproducible.

ACTUAL RESULT:
Missing pixels, see screenshot.

EXPECTED RESULT:
No missing pixels.

PLATFORM AND BUILDS TESTED:
Bug occurs in Mozilla nightly trunk build 2003-08-04-05 on Linux
Bug does NOT occur in Mozilla 1.3.1 on Linux
Bug does NOT occur in Mozilla 1.0.2 on Linux

ADDITIONAL INFORMATION:
Covering/uncovering the window repaints all pixels correctly.
Just hovering the link ("Power from blood...") also repairs the damaged area.
(Reporter)

Comment 1

15 years ago
Created attachment 129329 [details]
Screenshot
(Reporter)

Comment 2

15 years ago
Created attachment 129330 [details]
Somewhat reduced testcase
(Reporter)

Comment 3

15 years ago
It appears the bug only occurs if the mouse passes over the link on the way
back up.  Doing the selection/unselection by dragging the mouse outside the
green box does not trigger the bug.
(Reporter)

Comment 4

15 years ago
Created attachment 129332 [details]
Testcase (standalone)

Some observations:
1. Bug only occurs if the whole thing is wrapped in <div align="center">
2. The x position of the "vertical line" where the damage occurs coincides with

   the right edge of the first cell in the upper table (content "XXX") -
   add a few characters and the damage moves right.
3. Bug does not occur if I remove the <p><p> after the upper table
Attachment #129330 - Attachment is obsolete: true
(Reporter)

Comment 5

15 years ago
Making the point 2. above a bit more precise:
The x position of damage coincides the right edge of the (upper table) cell
that the mouse is moved into on the way up.
Keywords: testcase
(Reporter)

Updated

15 years ago
Summary: A part of the view is shifted 1px to the left when unselected → A part of the view is shifted 1px to the left when unselecting text

Comment 6

15 years ago
WFM on WinXP Moz 2003080304
(Reporter)

Comment 7

15 years ago
OK, in that case it's probably limited to Gtk
Assignee: kmcclusk → blizzard
Component: GFX → GFX: Gtk
Keywords: pp
I suspect this is a rounding problem somewhere combined with the fact that we
union invalidate rects before painting (see patch in bug 215303).
(Reporter)

Comment 9

15 years ago
*** Bug 227932 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

15 years ago
Created attachment 137184 [details]
Testcase #2  (from bug 227932)
(Reporter)

Comment 11

15 years ago
Note that the bug only occurs when the pref "Display resolution" is set to
"System setting" and the system dpi is for example:
91 x 92 (what I have)  
90 x 89 (reporter in bug 227932)
"116dpi" (dbaron)

Changing the pref to "96 dpi" makes the problem go away.
(Reporter)

Updated

14 years ago
Blocks: 251611
(Reporter)

Comment 12

11 years ago
Can anyone still reproduce this bug in a recent trunk build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

I haven't seen it in a long time, but my screen is now 101x101 dpi so that
might have something to do with it.  See comment 11.
Whiteboard: CLOSEME 07/01
(Reporter)

Comment 13

11 years ago
-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.