If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Registry permissions don't allow unprivileged users to run Mozilla

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Karl Kowallis, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

After installing Mozilla as local Administrator the browser started fine for
Administrator User. When logging in as a Power User Mozilla would not open. 

Comparing Regmon logs for the two users led to the registry key access denied for 
HKLM\SOFTWARE\mozilla.org\GRE\1.4f_2003062408 
which had full permissions for members of the Administrators group and SYSTEM.
No other groups had any read permissions.

Adding a read entry to the HKLM\SOFTWARE\mozilla.org for everyone solved the
problem and allowed normal users to run Mozilla.

Reproducible: Always

Steps to Reproduce:
1.Install Mozilla on W2k SP4 with a browser only install as Administrator
2.Run Mozilla as no administrator user
3.

Actual Results:  
When running as non-administrator process starts and then immediately exits.

Expected Results:  
Mozilla should have started.

When running as "Power User"
155	9.79461222	mozilla.exe:784	QueryValue
HKLM\System\CurrentControlSet\Services\Winsock2\Parameters\Ws2_32NumHandleBuckets
NOTFOUND		
156	9.79469268	mozilla.exe:784	CloseKey
HKLM\System\CurrentControlSet\Services\Winsock2\Parameters	SUCCESS	Key: 0xE23F8660	
157	9.79536735	mozilla.exe:784	OpenKey
HKLM\Software\mozilla.org\GRE\1.4f_2003062408	ACCDENIED	Access: 0x1
TEANCUM\kowallis	
158	9.80144773	mozilla.exe:784	CloseKey	HKCU\CLSID	SUCCESS	Key: 0xE2AE3280	
159	9.80152567	mozilla.exe:784	CloseKey
HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer	SUCCESS	Key: 0xE2CF1320	
160	9.80485291	mozilla.exe:784	CloseKey	HKLM	SUCCESS	Key: 0xE2A73E60	
161	9.80493672	mozilla.exe:784	CloseKey	HKCU	SUCCESS	Key: 0xE2D05B80	
162	9.80498700	mozilla.exe:784	CloseKey	HKCU	SUCCESS	Key: 0xE23BDB00	

When running as Administrator
155	3.90054158	mozilla.exe:420	QueryValue
HKLM\System\CurrentControlSet\Services\Winsock2\Parameters\Ws2_32NumHandleBuckets
NOTFOUND		
156	3.90062036	mozilla.exe:420	CloseKey
HKLM\System\CurrentControlSet\Services\Winsock2\Parameters	SUCCESS	Key: 0xE13E7CE0	
157	3.90098744	mozilla.exe:420	OpenKey
HKLM\Software\mozilla.org\GRE\1.4f_2003062408	SUCCESS	Key: 0xE2BAD2C0	
158	3.90105952	mozilla.exe:420	QueryValue
HKLM\Software\mozilla.org\GRE\1.4f_2003062408\GreHome	SUCCESS	"C:\Program
Files\Common Files\mozilla.org\GRE\1.4f_2003062408"	
159	3.90112238	mozilla.exe:420	QueryValue
HKLM\Software\mozilla.org\GRE\1.4f_2003062408\GreHome	SUCCESS	"C:\Program
Files\Common Files\mozilla.org\GRE\1.4f_2003062408"	
160	3.90120786	mozilla.exe:420	CloseKey
HKLM\Software\mozilla.org\GRE\1.4f_2003062408	SUCCESS	Key: 0xE2BAD2C0	
161	4.29840460	mozilla.exe:420	OpenKey
HKLM\System\CurrentControlSet\Control\Session Manager	SUCCESS	Key: 0xE2CC1820	
162	4.29847752	mozilla.exe:420	QueryValue
HKLM\System\CurrentControlSet\Control\Session
Manager\AdditionalBaseNamedObjectsProtectionMode	NOTFOUND
(Reporter)

Comment 1

14 years ago
Created attachment 129339 [details]
regmon log when running as "Power User"
(Reporter)

Comment 2

14 years ago
Created attachment 129340 [details]
regmon log when running as user Administrator

Comment 3

14 years ago
Did you check the registry access permissions for this key?

HKLM\SOFTWARE\mozilla.org\GRE\[named like the version number]

How to check? Run regedt32.exe, select window HKEY_LOCAL_MACHINE ... go to the
key above and select it on the left side. Open the menu Security - Permissions.

For me it works on Windows NT4, 2000 and XP. Have you tried it with 1.6 final?
(Reporter)

Comment 4

14 years ago
Manually editing the registry permissions solved the problem. I have had other 
registry permission problems and I think the problem is that somehow the 
permissions were damaged and the inhereited permissions were messed up.

I have since then re-installed my OS, and things seem to be working fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.