java 2 plugin libjavaplugin_oji.so can't be initialized due to missing symbol __vt_17nsGetServiceByCID

RESOLVED DUPLICATE of bug 214899

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 214899
15 years ago
10 years ago

People

(Reporter: Luis Mochan, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

In order to view the page http://www.idra.unige.it/~irro/java/conformi1_1.html,
the browser detected that I required a plugin for application/x-java-vm.
Following the browser's prompts, I downloaded the application from
http://wp.netscape.com/plugins/jvm.html. The download was apparently succesful
However, when restarting MozillaFirebird, I received the error message 

LoadPlugin: failed to initialize shared library
/usr/local/src/MozillaFirebird/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so
[/usr/local/src/MozillaFirebird/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so:
undefined symbol: __vt_17nsGetServiceByCID]


Reproducible: Always

Steps to Reproduce:
1.Enter http://www.idra.unige.it/~irro/java/conformi1_1.html
2.Click 'OK' in pop-up window to download plugin
3. Click 'Java 2 Linux Plug-in' in resulting pop-up window
4. Wait till plugin is succesfully installed
5. Quit mozilla firebird
6. Restart mozilla firebird
Actual Results:  
In the terminal from which I launched mozilla firebird I got the message 

 LoadPlugin: failed to initialize shared library
/usr/local/src/MozillaFirebird/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so
[/usr/local/src/MozillaFirebird/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so:
undefined symbol: __vt_17nsGetServiceByCID]

The message was repeated when I tried to enter 

http://www.idra.unige.it/~irro/java/conformi1_1.html

and the browser asked again if I wanted to load a plugin...

Expected Results:  
The plugin should have worked...

I am running under RH7.2

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 214899 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.