Tasks arenot published to remote modDAV server, and lost.

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
15 years ago
12 years ago

People

(Reporter: lundman, Assigned: mikeypotter)

Tracking

({dataloss})

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.4) Gecko/20030707
Build Identifier: Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.4) Gecko/20030707 and 1.4 on Windows 2000.

Set up modDAV, and calendar file to auto-sync, between my NetBSD and home
Windows 2k. Both running release 1.4. Deleted "My Calendar" so only the "shared"
calendar exists for both of us. New events work beautifully. But "Tasks" are not
sent to modDAV, and completely lost of close/re-open calendar window.

Reproducible: Always

Steps to Reproduce:
1.Share calendar. (potentially only have the shared calendar, no locals)
2.New Tasks (File, and right click day is the same)
3.Close, re-open calendar.

Actual Results:  
Event is nowhere to be found. No entries in apache logs that it has tried to
POST, suspect code for sharing Tasks are just not there.


Expected Results:  
Export/shared Tasks identically to Event. Please ;)

Comment 1

15 years ago
confming
Mozilla Calendar 2003080411-cal
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030720

task does only publish if you right clickc calendar and publish entire calendar.
if you create one task, nothing happens, no upload.
if you then create an event, the event gets published, and the tsk disappers
since it is not found on the server.

Comment 2

15 years ago
I also see this problem on current CVS builds on Linux.

Additionally, it is impossible to selectively publish tasks, sice the 'Publish'
menu-item is greyed out if you highlight a task from the task list - publishing
other events is possible in this way.

Comment 3

15 years ago
sorry for the spam - I forgot half of what I wanted to say ...

This problem can lead to dataloss for the user in case that person (like I did)
switches over to using remote calendars only: I configured Calendar to use a
newly created DAV calendar, and deleted the local calendar. I then added some
appointments and tasks, and received no feedback that a problem might have
occurred. I then closed the calendar. When I came back two days later, I found
no tasks in the calendar, and by now had forgotten what I had entered.

Even if there is no immediate fix for the underlying problem (tasks are not
published to a remote calendar), it would be wise to at least catch this
condition, and somehow warn the users that their tasks will be lost.

@Jorgen: keyword 'dataloss' might be justified here

Comment 4

15 years ago
keyword 'dataloss' (comments #1 and #3)
OS->All
Severity->major (since dataloss can result)
Severity: normal → major
Keywords: dataloss
OS: other → All

Comment 7

15 years ago
Yes, this works now for me - great, thanks for fixing it! :-)

Updated

15 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

15 years ago
Confirmed working well, no loss of entries so far. Thanks for the hard work.

Lundy

Comment 9

15 years ago
*** Bug 218924 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
*** Bug 193335 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
*** Bug 217780 has been marked as a duplicate of this bug. ***
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.