Seach panel in sidebar doesn't working well

VERIFIED INVALID

Status

()

VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.4) Gecko/20030624

Yes, I know in FB is not search panel yet fully implementes, but with WebBar
from http://basic.mozillanews.org/ it can be diplayed in the FireBird Sidebar.
Yes, displayed, but doesn't working much.

Search plugins and search panel in sidebar are very usefull in Mozilla, please
complete their implementation in the FB also.

Reproducible: Always

Steps to Reproduce:
1. Install webbar FB extension to FB 0.6 or FB 0.6.1
2. Open Search panel in the sidebar
3. Choose some engine and try search form something

Actual Results:  
a) Always is used only the First search engine. There is not possible to change
to any other (you can check any, but only the first in the list is used).

b) The search results are not displayed in the search panel



Expected Results:  
Users want to choose any seach engine and see search results in the left panel.
Bugs on extensions shouldn't be filed in bugzilla.mozilla.org. They should be
reported to the extension author.

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Please reconsider. It looks like the code needed by the search sidebar (which
was in the Seamonkey suite) was removed from FB. This code has to be identified
and eventually put into FB itself.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 3

16 years ago
Thank comm #2.

The problem is not in code of WebBar, because WebBar only allow you to display
Search Panel from FB code. And because in FB installation Search Panel wasn't
used, his code is probably corrupted and nobody tested it before.

So reconsider, if you want Seach Panel in the FB.
If yes, there is some problem in the code in comm.jar!content/communicator/search
The code is not there for a reason. If the webbar extension wants to have this
extension, it should supply that code.

-> INVALID again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
QA Contact: asa → bugzilla
Resolution: --- → INVALID
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b)
Gecko/20030817 Mozilla Firebird/0.6.1+
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → mpconnor
You need to log in before you can comment on or make changes to this bug.