unable to launch the composer with a "mozilla -edit" command if there is already a mozilla session running - it reports that the profile is already in use even though we can launch another browser window with "mozilla"

RESOLVED DUPLICATE of bug 192553

Status

SeaMonkey
Build Config
RESOLVED DUPLICATE of bug 192553
15 years ago
13 years ago

People

(Reporter: ngrover, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203

If I have a Mozilla session already running, I can successfully launch a new
window, within that same session, by running "mozilla". However, if I run
"mozilla -edit", then it tries to start a new session and requires a different
profile.

I saw this problem using Mozilla versions 1.2 (1.2.1-0_rh7) and 1.4 (1.4-0.7.3).

Reproducible: Always

Steps to Reproduce:
1. run "mozilla &" to launch a Mozilla session
2. run "mozilla" and this will successfully launch a new window
3. run "mozilla -edit" and you will not be able to launch the Composer using the
same profile
Actual Results:  
I am forced to create or use a different profile if I want to launch the
Composer with "mozilla -edit".

Expected Results:  
Mozilla should have opened a Composer window using the same profile, as it does
if I click Window -> Composer or press [ctrl]+[4] in one of the Mozilla windows
that is already up.
startup script problem...
Assignee: composer → blizzard
Component: Editor: Composer → Build Config

Comment 2

15 years ago
RPM startup script uses XRemote which doesn't support composer

dupe of "Add -remote (URL,composer) to start Mozilla Composer (Editor) via
commandline"

*** This bug has been marked as a duplicate of 192553 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.