Page not displayed correctly when Sidebar is visible (Windows and Linux)

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: edwardp, Assigned: bernd_mozilla)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reflow-refactor][line-breaking], URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

This web page does not display correctly in Mozilla 1.4, for BOTH Windows 98 and
Linux, when the Sidebar is diaplayed.  

The page displays similiar to a checkerboard pattern (the end of one line
appears at the beginning of the next line, then ends there).  However when the
Sidebar is closed either by clicking its X or pressing F9, the page then
displays correctly (in both Windows and Linux).  

View/Page Source indicates MS Front Page 4.0 was used to create the page, so I
am not sure if -that- is the reason for Mozilla 1.4 not displaying it properly
with the Sidebar visible.


Reproducible: Always

Steps to Reproduce:
1.With Sidebar visible, go to http://www.cmedia.com.tw/
2.Web page displays incorrectly
3.Close Sidebar, page displays correctly



Expected Results:  
Page should have displayed correctly whether or not Sidebar is visible.  Not
known if their use of MS Front Page 4.0 to write the page, is causing Mozilla to
display the page as described.
(Reporter)

Comment 1

16 years ago
*** Bug 215630 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
Well, when I look at it in 2003080808 PC/WinXP, it's broken even with the
Sidebar off....

->Layout
Assignee: general → other
Component: Browser-General → Layout
QA Contact: general → ian

Comment 3

16 years ago
I see it to on Win 2003080504
There is a table that holds all the images.  Each row has four images that have
a combined width of  726px.  On my screen Mozilla makes the width of the table
666px (67%) in width. This is not enough to hold the images so it wraps the
images to the next line.
The sidebar is just decreasing the width of the page so the images now have to
wrap.  Frontpage is taking avantage of a bug in IE.
-> Tables
Assignee: other → table
Status: UNCONFIRMED → NEW
Component: Layout → Layout: Tables
Ever confirmed: true
Keywords: testcase
QA Contact: ian → madhur
(Assignee)

Comment 6

16 years ago
setting the cellspacing to 0 would also avoid the wrapping
Assignee: table → bernd_mozilla
(Assignee)

Comment 7

16 years ago
Created attachment 129544 [details] [diff] [review]
patch
(Assignee)

Comment 8

16 years ago
Comment on attachment 129544 [details] [diff] [review]
patch

the patch fixes only the flaw in the layout strategy the wrapping issue
<img><img> is untouched
Attachment #129544 - Flags: superreview?(dbaron)
Attachment #129544 - Flags: review?(john)
Comment on attachment 129544 [details] [diff] [review]
patch

Given how the caller uses this, this sounds right.
Attachment #129544 - Flags: review?(john) → review+
(Assignee)

Comment 10

16 years ago
fix checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.