Closed Bug 215631 Opened 18 years ago Closed 18 years ago

Focus is stolen by input controls if another tab is open

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 124750

People

(Reporter: n30n, Assigned: saari)

References

()

Details

(Whiteboard: DUPEME)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

If you load the url in the background while viewing another page ( specifically
with another input field selected ( even better if you are editing it's contents
) ) the input on the form will steal the focus from the current tab. This also
happens with robotskull babble (
http://www.robotskull.com/robotskull/index.cgi?page=babble ). I assume that this
is a problem with javascript stealing the focus from other controls, but I am
not sure ( read : probably wrong ).

Reproducible: Always

Steps to Reproduce:
1. Load the given url ( or the robotskull babble one )
2. Switch to another tab ( specifically one with an input field )
3. Start typing in the input field.

Actual Results:  
When the gu page has loaded, the focus will be stolen from the currently selcted
input field, by the input field on the gu tab, and any text entered will be
shown in that field.

Expected Results:  
Input fields in background tabs should not be able to steal focus from the
currently selected tab. Instead their focus settings should be kept for when the
tab is brought to the foreground.
->event handling
Assignee: other → saari
Component: Layout → Event Handling
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.