If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FLOAT] Table layout problems

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Michael Lowe, Assigned: buster)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
Problem with cited URL.  Boils down to attached test case.   Text is throw out
of table when PARAM tag is encountered.
(Reporter)

Comment 1

18 years ago
Created attachment 3431 [details]
Test case
(Reporter)

Updated

18 years ago
Assignee: rickg → troy
Component: Parser → Layout
(Reporter)

Updated

18 years ago
Summary: Text thrown out of table → Table layout problems
(Reporter)

Comment 2

18 years ago
I was probably a little over zealous in reducing test case (which is probably
invalid).   It actually seems like a table or layout problem.   See new attached
test case - table starting with "Monday, 13 December, 1999, 14:04 GMT" is
shifted down more than it should be.
(Reporter)

Comment 3

18 years ago
Created attachment 3433 [details]
layout testcase
(Reporter)

Comment 4

18 years ago
Created attachment 3434 [details]
better layout testcase

Updated

18 years ago
Assignee: troy → karnaze
Component: Layout → HTMLTables

Comment 5

18 years ago
Looks like a table problem to me, too
(Reporter)

Comment 6

18 years ago
*** Bug 21915 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
Created attachment 3593 [details]
Testcase distilled from http://news.bbc.co.uk

Updated

18 years ago
Whiteboard: [TESTCASE]

Comment 8

18 years ago
The problem is that the right floating table is moved below the left floating
table. I think the problem is that there is some layout space allocated between
the tables (which makes the right one slip down cause there isn't room for it).
If you agree, this bug can be marked as a duplicate of bug 18166.

Updated

18 years ago
Assignee: karnaze → kipp

Comment 9

18 years ago
I removed the width=430 from the outer table of the 4th attachment. The block
frame is reporting too large a desired height. It is adding 570 (twips) and 330
to arrive at 900 and this is wrong. Reassigning to Kipp.

          TC::Rfl 00D4AD30 rea=2 av=(6510,UC) comp=(6510,UC)
            Area::Rfl en 00D4AD90 rea=2 av=(6510,UC) comp=(6510,UC)
            TO::Rfl en 00D4AE14 rea=2 av=(6510,UC) comp=(1500,UC)
              T::Rfl en 00D4AE64 rea=2 av=(1500,UC) comp=(1500,UC)
                TRG::Rfl 00D4AED0 rea=2 av=(1500,UC) comp=(1500,UC)
                  TR::Rfl en 00D4AF10 rea=2 av=(1500,UC) comp=(1500,UC)
                  TR::Rfl ex 00D4AF10 des=(1500,570)
                TRG::Rfl ex 00D4AED0 des=(1500,570)
              T::Rfl ex 00D4AE64 des=(1500,570)
            TO::Rfl ex 00D4AE14 des=(1500,570)
            TO::Rfl en 00D4B154 rea=2 av=(4950,UC) comp=(0,UC)
              T::Rfl en 00D4B1A4 rea=2 av=(4890,UC) comp=(4890,UC)
                TRG::Rfl 00D4B210 rea=2 av=(4950,UC) comp=(4950,UC)
                  TR::Rfl en 00D4B250 rea=2 av=(4950,UC) comp=(4950,UC)
                  TR::Rfl ex 00D4B250 des=(4950,45)
                  TR::Rfl en 00D4B720 rea=2 av=(4950,UC) comp=(4950,UC)
                  TR::Rfl ex 00D4B720 des=(4950,285)
                TRG::Rfl ex 00D4B210 des=(4950,330)
              T::Rfl ex 00D4B1A4 des=(4950,330)
            TO::Rfl ex 00D4B154 des=(4950,330)
            Area::Rfl ex 00D4AD90 des=(6510,900)
          TC::Rfl ex 00D4AD30 des=(6510,900)
(Assignee)

Updated

18 years ago
Summary: Table layout problems → [FLOAT] Table layout problems
(Assignee)

Comment 10

18 years ago
moving kipp's bugs to M15.  Some will get moved again, this is just a start.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
(Reporter)

Updated

18 years ago
Whiteboard: [TESTCASE]
URL and last 3 testcases works for me in build 2000021615 on Windows NT 4.0 sp6.
Maybe it was fixed by the change mentioned in bug 23299.
First testcase is IMO a different problem, filed a new bug on that: bug 28210.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 13

18 years ago
mine now
Assignee: kipp → buster
Status: RESOLVED → NEW
(Assignee)

Comment 14

18 years ago
accidentally cleared WorksForMe resolution
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago

Comment 15

17 years ago
Verified
Platform: PC
OS: Windows 98
Mozilla Build: 2000101020 M18 Trunk Build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.