Focus lost when switching tabs

VERIFIED DUPLICATE of bug 120148

Status

()

Core
Event Handling
VERIFIED DUPLICATE of bug 120148
14 years ago
14 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: Brian Ryner (not reading))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:

1. start browser (seamonkey or firebird) 
2. open a new tab (so you have two tabs open)
3. load www.google.com in the new tab. the search box receives focus once the
page has loaded.
4. switch to the first tab
5. switch back to the google tab

Expected results:
- search box is still focused (caret blinking) in the google tab

Actual results:
- focus went away. 

Notes: if I type, nothing appears in the field (in fact, find-as-you-type is
invoked) but the page still has the notion that the search box is focused,
because if I hit TAB, focus shifts to the "Google Search" button which is the
next in the tabbing order from the search box which should have been focused.

*** This bug has been marked as a duplicate of 120148 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
vrfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.