username prompt (when multiple usernames apply) should indicate which tab it is referring to

RESOLVED DUPLICATE of bug 121209

Status

SeaMonkey
Passwords & Permissions
--
minor
RESOLVED DUPLICATE of bug 121209
15 years ago
13 years ago

People

(Reporter: Alonso Acuña, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

When several tabs are loading at the same time and there is one tab that loads a
page for which there are at least 2 saved passwords, a dialog will come up
asking to choose one of the usernames but it does not indicate which of the tabs
is the one asking. So if several tabs happen to show the same dialog there would
be no way to know what one is doing.

Reproducible: Always

Steps to Reproduce:
1.load 2 tabs with different domains for which you have saved at least two passwords
2. save the tabs as a bookmark
3. close tall
4. load bookmark

Actual Results:  
browser asks which username but you don0t know which site it is asking for
because the dialog does not say.

Expected Results:  
The dialog should simply say the domain or the title of the page or maybe select
the tab in question.

Comment 1

15 years ago
This problem isn't specific to the "select user" dialog...
bug 121209, Hard to match error dialogs to "owning" tab
bug 123913, [RFE] tab-specific alerts are app-modal and should be tab-modal
(need "sheets" widgets on non-MacOSX)

Comment 2

14 years ago
I think this is a dupe of bug 121209, at least as I read it. I'm going to mark
it as such, please re-open if there are disagreements. Thanks.

*** This bug has been marked as a duplicate of 121209 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.