XMLHttpRequest used cached page when told not to

RESOLVED DUPLICATE of bug 200706

Status

()

Core
XML
--
major
RESOLVED DUPLICATE of bug 200706
15 years ago
14 years ago

People

(Reporter: Jeremy Hartley, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718

When my Caching preferences are set to: 
Compare the page in the cache to the page on the network: Every Time I view the
Page.

XMLHttpRequest doesn't behave the way it is supposed to. If I request an XML
file it opens it fine. If I then update the XML file, the original unchanged XML
file is retrieved. I.e. the cached version.

Reproducible: Always

Steps to Reproduce:
0. Set Caching preferences to: 
Compare the page in the cache to the page on the network: Every Time I view the
Page.

1. create file data.xml.

2. Read it with the following function and read output somehow:
function requestXML(){		
//Create XMLHttpRequest 
var xmlhttp;
xmlhttp = new XMLHttpRequest();

//Grab XML off Apache
xmlhttp.open("GET", "http://jeremy/test/data.xml",true);
xmlhttp.onreadystatechange=function() {
//Function for when xml is loaded
if (xmlhttp.readyState==4) {			
//Read through output and create simple page displaying results					doc =
xmlhttp.responseXML;	
generatePopUp(doc);
}
}

xmlhttp.setRequestHeader("Content-Type", "text/xml")								
//make the actual request
xmlhttp.send(null);
}

3. Change XML file and read output. 
Actual Results:  
The output of reading the XML should have changed to reflect the changes made to
it however the results are the same as the first time the file was viewed. 

Expected Results:  
Mozilla should have retrieved the xml file from the web server instead of using
a cached version.
Sounds like XMLHttpRequest is overriding the preference...
Assignee: gordon → hjtoi-bugzilla
Component: Networking: Cache → XML
QA Contact: cacheqa → ashishbhatt

Comment 2

15 years ago
I think the headers are just cached.  When I send an HTTP 304 status code from
my server, Mozilla is reading HTTP 200.

*** This bug has been marked as a duplicate of 200706 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.