can't disable stylesheet if it has no title

RESOLVED DUPLICATE of bug 32372

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 32372
15 years ago
12 years ago

People

(Reporter: WG9s, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718

If a web page loads a stylesheet, but does not specify a title as in:

 <link rel="stylesheet" href="/styles.css" type="text/css" media="screen">

Then it is not possible via Mozilla to render the page ignoring the style
sheet.  This is becuase the View -> Use Style has only one choice in this
case. 

When you load the page http://www.raytheon.com/newsroom/  which has the above
stylesheet reference the problem exhibits itself.  If you load the page
http://www.raytheon.com/  which uses the exact same stylesheet, but I changed
the reference to:

 <link rel="stylesheet" href="styles.css" type="text/css" media="screen"
title="main">

you can render the page ignoring the stylesheet.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.raytehon.com/newsroom/
2. Go to the View -> Use style menu
3.

Actual Results:  
Only one choice is displayed

Expected Results:  
Given you the option to view the page without the style sheet

Comment 1

15 years ago
See also bug 51686 comment 1, bug 51690 and the long discussion on bug 6782.

*** This bug has been marked as a duplicate of 32372 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
*** Bug 315391 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.