Last Comment Bug 215846 - No way to tab to attachment pane using keyboard
: No way to tab to attachment pane using keyboard
Status: VERIFIED FIXED
: access
Product: MailNews Core
Classification: Components
Component: Composition (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Yuliy Pisetsky
: esther
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-11 12:13 PDT by Yuliy Pisetsky
Modified: 2008-07-31 01:22 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
fixes typo in AttachmentElementHasItems() in MsgComposeCommands.js (684 bytes, patch)
2003-08-11 12:15 PDT, Yuliy Pisetsky
mscott: review+
mozilla: superreview+
Details | Diff | Splinter Review
This should fix the remaining issues (4.66 KB, patch)
2003-11-28 15:39 PST, neil@parkwaycc.co.uk
mscott: review+
mozilla: superreview+
Details | Diff | Splinter Review

Description Yuliy Pisetsky 2003-08-11 12:13:17 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030805
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030805

When composing a message, after attaching a file, you should be able to tab over
to the attachment pane to delete it using keyboard. However even with a file
attached, still cannot tab over

Reproducible: Always

Steps to Reproduce:
1. open mailnews, click compose
2. attach any file
3. try to tab into attachment pane (should be between subject and body according
to the .js file)

Actual Results:  
Goes right past it (from subject to body and body to subject)

Expected Results:  
tabbed from subject to attachments and shift-tabbed from body to attachments

Attaching a patch that might fix this
Comment 1 Yuliy Pisetsky 2003-08-11 12:15:14 PDT
Created attachment 129604 [details] [diff] [review]
fixes typo in AttachmentElementHasItems() in MsgComposeCommands.js

what do I do with this now?
Comment 2 Simon Paquet [:sipaq] 2003-11-05 06:11:15 PST
Comment on attachment 129604 [details] [diff] [review]
fixes typo in AttachmentElementHasItems() in MsgComposeCommands.js

Scott, David can you please review?
Comment 3 David :Bienvenu 2003-11-05 07:31:46 PST
Scott or I can check this in for you...
Comment 4 Simon Paquet [:sipaq] 2003-11-05 08:10:52 PST
Thanks David. That would be nice. And just to rule out any misunderstandings. I
only seeked review, npisetsky@cox.net wrote the patch and should be credited.

Another question: 
Since this is a pretty low-risk patch, should I ask for approval for 1.4.2, too?
Comment 5 David :Bienvenu 2003-11-05 08:17:56 PST
you can seek approval - I'm not sure if it would be considered important enough
for 1.4.2, even though it is low risk.
Comment 6 Scott MacGregor 2003-11-05 12:50:30 PST
Comment on attachment 129604 [details] [diff] [review]
fixes typo in AttachmentElementHasItems() in MsgComposeCommands.js

no this should just got into the 1.6 trunk and not a point release for previous
releases. The issue isn't severe enough to warrent that.
Comment 7 Simon Paquet [:sipaq] 2003-11-06 15:08:50 PST
I won't seek approval for the 1.4-BRANCH. So if you David or Scott could check
this into the trunk, that would be great.
Comment 8 David :Bienvenu 2003-11-06 15:10:34 PST
sure, I'll check it in.
Comment 9 David :Bienvenu 2003-11-06 15:27:44 PST
this patch didn't work for me, unfortunately. I'll try a cleaner rebuild.
Comment 10 Yuliy Pisetsky 2003-11-11 00:06:44 PST
Okay, I still think that fix is valid, but I did some poking as to why it didn't
fix the problem at hand, and I found that in 2003102804, I couldn't get it to go
to the attachment pane, _even if I disabled the check for attachments in the
pane_. It still went right on past it. 
Comment 11 Yuliy Pisetsky 2003-11-11 00:08:46 PST
(sry for spam, just realized comment was unclear) the check I referred to in the
previous comment is in the SwitchElementFocus function in the same .js file
Comment 12 David :Bienvenu 2003-11-11 08:28:10 PST
I agree - it seems neccesary but not sufficient. I guess I'll check it in and we
can figure out what else is broken.
Comment 13 Yuliy Pisetsky 2003-11-12 14:19:40 PST
Okay. I looked around a bit in messengercompose.xul, and apparently trying to
tab from subject calls subjectKeyPress instead of SwitchElementFocus. Another
thing: apparently, SwitchElementFocus is broken. It is only used when using
ctrl+tab or F6 (see <a
href="http://lxr.mozilla.org/mozilla/source/mailnews/compose/resources/content/messengercompose.xul#175">http://lxr.mozilla.org/mozilla/source/mailnews/compose/resources/content/messengercompose.xul#175</a>
). Using F6 from the message panejumps to the identity, F6/ctrl+tab after that
jumps back to the content pane. shift+F6 from the subject even leaves it there.
I'll try looking into what's going on there
Comment 14 Simon Paquet [:sipaq] 2003-11-12 15:13:08 PST
Over to Yuliy.
Comment 15 David :Bienvenu 2003-11-28 12:56:53 PST
i've checked in the fix for the typo with a larger checkin for cancelling fcc
operations.
Comment 16 neil@parkwaycc.co.uk 2003-11-28 15:39:52 PST
Created attachment 136476 [details] [diff] [review]
This should fix the remaining issues

I renamed addressingWidgetTree because it's not a tree, which makes the patch
bigger than it seems, the relevant parts are lines 2310, 2556, 2717 and 2745.
Comment 17 David :Bienvenu 2004-02-09 10:00:33 PST
Comment on attachment 136476 [details] [diff] [review]
This should fix the remaining issues

we need to do the same fix in tbird, I believe.
Comment 18 neil@parkwaycc.co.uk 2004-02-09 15:48:46 PST
Fix checked in to Seamonkey.
Comment 19 Yuliy Pisetsky 2004-02-13 00:19:55 PST
one last thing. ctrl+tab or F6 from subject goes to attachments if there are
attachments, as it should be, but tab does not. Why is there a separate function
to handle a tab in the subject line?
Comment 20 Mike Cowperthwaite 2004-03-02 10:12:03 PST
To follow up on Yuriy's comment 19: Shift-tab from the body doesn't go to the 
Attachments pane either; shift-Ctrl-Tab or shift-F6 do.  Is that intentional, or 
should there be a new bug opened?

See also bug 236219.


Note You need to log in before you can comment on or make changes to this bug.