cannot delete imap folder, client does not execute DELETE cmd (sniffed packets)

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
RESOLVED INVALID
15 years ago
10 years ago

People

(Reporter: Sebastian Lipponer, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

If I subscribe some IMAP folders and try to delete one of them by either right
click-->delete folder or edit-->delete Folder nothing appears to happen.
Due to this strange behaviour, I tcpdumped the IMAP traffic and analyzed the
packets. They contain no DELETE command. If I rename a folder, the command
appears in the dumped packets.

Reproducible: Always

Steps to Reproduce:
1. start Thunderbird
2. subscribe imap folder
3. choose a folder in the list on the left and choose by right click --> delete
folder.

Actual Results:  
Nothing. The folder is still visible in the list and on the server!

Expected Results:  
Folder should disappear in the list and on the server!

Comment 1

15 years ago
What kind of deletition have you set up (move to Trash|mark as deleted|delete
immi.)? I see a bit different behavior caused by 'move to trash' setup: response
from IMAP server is 'Trash already exists'...

Comment 2

15 years ago
This works perfectly on Linux, tbird 0.1 (20030727); and a collegue confirms the
same using 0.2 20030829 on WinXP.
(Reporter)

Comment 3

15 years ago
"Move it to the Trash folder" does not work because the "TRASH" folder has
another name. I am using a german E-Mail provider (www.gmx.net)! My "Trash"
folder would be "Gelöscht" in german.
Thus I need to configure the name for the folder which contains deleted
messages. This is still possible for drafts,templates and sent folders!

Updated

14 years ago
QA Contact: asa

Comment 4

14 years ago
If I remove "manually" the folder from the IMAP server, it stays in 
Thunderbird. Now if I try to remove it with Delete key or grag an drop into 
Trash, Thunderbird crashes with the following call stack :

MAIL! 01a72a56()
MAIL! 01a6bbc1()
MAIL! 01b7a2f3()
MAIL! 01b733a0()
MAIL! 01ae4e8a()
MAIL! 01a49466()
MAIL! 01a4709d()
RDF! 01609792()
MAIL! 01a39ffd()
XPCOM! 100379fe()
XPC3250! 01282256()
XPC3250! 01285646()
JS3250! 011eb5c6()
JS3250! 011f0725()
JS3250! 011eb608()
XPC3250! 012801f1()
XPC3250! 0127dc13()
XPCOM! 10036edc()
XPCOM! 100379fe()
XPC3250! 01282256()
XPC3250! 01285646()
JS3250! 011eb5c6()
JS3250! 011f0725()
JS3250! 011eb608()
JS3250! 011eb877()
JS3250! 011d4971()
JSDOM! 01784241()
JSDOM! 0179f89a()
GKLAYOUT! 018f61e9()
GKLAYOUT! 018f7f11()
GKLAYOUT! 018f04d6()
GKLAYOUT! 018f0536()
GKLAYOUT! 0189bcdf()
GKLAYOUT! 018fd654()
GKLAYOUT! 01920e83()
GKLAYOUT! 01920e5c()
GKLAYOUT! 01920e5c()
GKLAYOUT! 01920e5c()
GKLAYOUT! 01920e5c()
GKLAYOUT! 017dc681()
GKLAYOUT! 017dc37d()
GKLAYOUT! 0190b9c8()
GKLAYOUT! 0190d75c()
GKLAYOUT! 0190de57()
GKWIDGET! 01581f00()
GKWIDGET! 0158389b()
GKWIDGET! 01583a33()

Comment 5

14 years ago
I ran into same problems unable to delete a IMAP folder from within TBird. After
manually deleting it on the IMAP server, it was stuck in TBird, which was unable
to manipulate it. This happened on both Linux and WXP.

I found a solution, this one's working on WXP, however, it's really ugly:

- close all running instances of TBird, Mozilla
- go to your profile dir
- cd ImapMail/servername
- delete concerned filename.
- delete concerned filename.msf
- go back to your profile dir
- edit contents of localstore.rdf (possibly make a backup first) to delete all
records with concerned folder name, the records start with <RDF: and end with
DOS's CRLF (my notepad displayed it as a small rectangle)

For Linux, there's still some other place where folderlist info is stored, I
hope I'll find out soon.

Comment 6

13 years ago
I too am unable to delete IMAP folders.  It did not work in 0.7 nor does it in
0.8.  If I create an empty folder and then go delete it I get this message:

The current command did not succeed.  The mail server responded: RENAME failed:
Can't create mailbox node /home/xxxx/imap/yyyy/mail/Trash/: File exists.

The Trash, btw, is empty.

If I then open Mozilla mail (1.7.2) I am able to delete the IMAP folder without
any problems.

Comment 7

13 years ago
It seems that this should be pretty simple to resolve.  It simply
doesn't make sense to try and move mail folders being deleted to
be a subfolder of the trash folder (at least knowing that trash
is a folder that contains messages, not a directory).  The proposed
work around of changing options to delete mail immediately works,
but users may be surprised if they don't change the setting back.
NB - the workaround instructions I found didn't say anything about
changing the settings back when the folders are deleted.

This bug has been around long enough, so why doesn't it get fixed?
It really isn't a feature.
Yes, this bug is really anoying & fixed since a few monthes on Mozilla
MailNews... The work-around I use is :

- delete on the IMAP server
- un-subscribe from within thunderbird

as dirty as it may be...

Comment 9

13 years ago
I am also experiencing this bug in version 1.0 (20041206).

Comment 10

12 years ago
hey, i experiance this all the time.  its a stupid bug and has been in mozilla since before the firefox/thunderbird split.  hurry up and fix this!  FYI also effects unix versions of the product, report just lists 2k.

Comment 11

12 years ago
This bug is still present in thunderbird 1.5.0.4. I am using dovecot 1.0rc2 IMAP server and Thunderbird 1.5.0.4 on windows with mbox mail format. 

When I try to delete a folder, Thunderbird tries to move the folder to the trash. This will never work with mbox formatted e-mail and deleting of the folder will fail. The workaround of setting "When I delete a message:" to Remove it immediately works, but is confusing since that option applies to both messages and folders.

I think some potential fixes could include:
* Have a seperate option called "When I delete a folder:" so folders can be deleted but individual messages will still be moved to the trash.

* When using mbox, and the user selects Delete folder, have Thunderbird move the messages within the folder to the trash and then delete the folder. Don't try to make the folder a subfolder of trash.

Comment 12

12 years ago
Have you un-checked the box in the advanced imap server settings that says "servers supports folders that contain sub-folders and messages"?

Comment 13

12 years ago
Thanks for cluing me into that option, David. Unchecking that fixes all the problems I was having.
QA Contact: front-end

Comment 14

11 years ago
David and Kareem,
Where do you find this "advanced imap server setting"? I am not a guru by any stretch, I can go to preferences or options. But I don't find this option. I have given up on ever deleting folders. I just move them into one location and let them accumulate. Every now and then I remember to pull one out and rename it.
Trixie

Comment 15

11 years ago
tools | account settings, server settings for your imap server - there's an advanced button on that page...
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 16

10 years ago
->INVALID. FIXED is used only when known code changes resolved the issue.
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.