Can't run Mozilla, Firebird, and Thunderbird concurrently

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: jhpedemonte, Assigned: jhpedemonte)

Tracking

({fixed1.4.1})

Trunk
x86
OS/2
fixed1.4.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

16 years ago
On OS/2, trying to run Firebird when Thunderbird is already open merely send
control over to the running mozilla-based app.  This is do to the MessageWindow
code in xpfe/bootstrap/nsNativeAppSupportOS2.cpp;  all three different
applications have the same message window ID.
(Assignee)

Comment 1

16 years ago
Taking.  Patch coming.
Assignee: nobody → pedemont
(Assignee)

Comment 2

16 years ago
Created attachment 129619 [details] [diff] [review]
patch

First, I changed the Message Window ID handling, so that all 3 apps don't share
the same ID.  Now, each app creates the ID from an Atom based on its name. 
However, even here, the msg window id is not guaranteed to be unique amongst
all running apps.  So if we find an running app that shares the same ID, we
double check that we also share the same window class name.  If so, then we get
the window handle of the running app and send it the requests.
This should be XP Apps.

/be
Component: XP Miscellany → XP Apps
Comment on attachment 129619 [details] [diff] [review]
patch

r=mkaply
sr=blizzard (platform specific)
a=mkaply for 1.4.1 and 1.5b
Attachment #129619 - Flags: superreview+
Attachment #129619 - Flags: review+
Attachment #129619 - Flags: approval1.5b+
Attachment #129619 - Flags: approval1.4.x+
(Assignee)

Comment 5

16 years ago
Created attachment 129670 [details] [diff] [review]
patch v1.1

Made it so if we have to add an atom for the class name, then assume the app
isn't running.	Also, added comments.
(Assignee)

Comment 6

16 years ago
Comment on attachment 129670 [details] [diff] [review]
patch v1.1

Kaply, what do you think of this one?  Is it better than the first patch?
Attachment #129670 - Flags: review?(mkaply)

Updated

16 years ago
Attachment #129670 - Flags: superreview+
Attachment #129670 - Flags: review?(mkaply)
Attachment #129670 - Flags: review+
Attachment #129670 - Flags: approval1.5b+
Attachment #129670 - Flags: approval1.4.x+

Updated

16 years ago
Attachment #129619 - Attachment is obsolete: true
Attachment #129619 - Flags: superreview+
Attachment #129619 - Flags: review+
Attachment #129619 - Flags: approval1.5b+
Attachment #129619 - Flags: approval1.4.x+
checked in to trunk and branch
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: fixed1.4.1
Resolution: --- → FIXED
*** Bug 216389 has been marked as a duplicate of this bug. ***
*** Bug 219691 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.