Refuses connection with message "The connection was refused when attempting to contact msid.msn.com"

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: Kenneth Irving, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3.1) Gecko/20030425

Every attempt at connection to msnbc.com main page or other pages on the site on
8/11/2003 produced the same message. No problem connecting to msn.com, which was
named in the error message. IE6 had no problem making the connection. I have no
way of knowing whether or not this is a Mozilla bug, so I am reporting the
problem here as well as to msnbc.com.

Reproducible: Always

Steps to Reproduce:
1. Just type in the URL or click on a link to an msnbc.com page.
2.
3.

Actual Results:  
Error message reported above. Connection refused.

Expected Results:  
Connected.

Comment 1

15 years ago
Works for me on 12 Aug 2003, try again and contact me if it still isn't working
for you...

Comment 2

15 years ago
This sounds like a temporary network issue with an iframe based ad. Mozilla will
fire an alert if a loaded domain is not accessible while IE doesn't, so you may
have had the same inaccessible domain in both but only seen the alert in Mozilla.

This works for me today in Mozilla 1.4/win2k.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

15 years ago
Problem solved, though not fully understood. It has something to do with the
differing ways in which IE6 and Mozilla use a "hosts" file intended for ad
blocking. IE6 seems to block the ads, but has no problem going to sites in the
hosts file, while Mozilla doesn't seem to block ads but refuses to go to the
sites. Any effort to go to msnbc.com (whether link or typing it in) goes through
msid.msn.com, which is in the hosts file. I was clued into this when I cam across 

http://www.deftone.com/blogzilla/archives/error_page_for_inaccessible_pages.html

which mentions a fix for bug 28586 in a post dated July 16, 2002. After removing
msid.msn.com from the hosts file, I was able to connect to msnbc.com.

Comment 4

15 years ago
Kenneth, I am tempted to move this to networking. Before I do that, can you tell
me what you had in your hosts file for msid.msn.com ?
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.