mozilla should? accept forward slash as delimiter between "domain" and "user" [was: no Access after Firewall / Proxy]

RESOLVED DUPLICATE of bug 214599

Status

()

P5
enhancement
RESOLVED DUPLICATE of bug 214599
15 years ago
15 years ago

People

(Reporter: bartels, Assigned: darin.moz)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ntlm-auth] [possibly WONTFIX])

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; de-DE; rv:1.0.2) Gecko/20030208 Netscape/7.02
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; de-DE; rv:1.0.2) Gecko/20030208 Netscape/7.02

There is a known bug (67465, 45378,..) accessing the world through a firewall / 
proxy. The popUp Windows is cleared and nothing happens.
The problem is fixed in Netscape 7.02, but it doesn't work in Netscape 7.1,
Mozilla 1.4 and Mozilla 1.5 anymore.
Regards Klaus

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
no connection to the internet

Expected Results:  
proxy authentication

Comment 1

15 years ago
*** Bug 215913 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
*** Bug 215911 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
The bugs you mentioned are resolved as fixed or worksforme, 
Bug 45378 should be reopened from what I see from your too short description and
that one in that bug.
You can´t have tested Mozilla 1.5, so what did you test?
Mozilla releases 1.4 and 1.5a, or current nightlies?
Can you post Build IDs? They can be seen in the title of nightlies, and can be
copied and pasted from about:Mozilla

verified fixed: 
Bug 67465 Mozilla prompts for id & pass when accessing sites w/ certificates
from behind a firewall

verified/worksforme: 
Bug 45378 Pop up authentication window for firewall proxy still doesnt work
correctly.
What do you mean with "The popUp Windows is cleared and nothing happens." ?
If you use a MS Proxy with NTLM and also basic Auth :
Do you use the username "DOMAIN\USERNAME" instead of "USERNAME" ?

Please attach a Http log if this isn't true or if that doesn't work :
http://www.mozilla.org/projects/netlib/http/http-debugging.html

There is no reason to reopen the old and useless bug 45378

-> major (doesn't block Mozilla development)
Severity: blocker → major
(Reporter)

Comment 5

15 years ago
Yes, I mean the Pop up authentication window. I have to enter "Domain name" and
"Userid" in the first line and my password in the second line (works with
Netscape 7.02). Tomorrow I am working again with the PC behind the firewall
proxy and I will give you the missing information.

(Sorry for the duplicate records, there was a problem with the data transmission)
(Reporter)

Comment 6

15 years ago
I found the reason: netscape 7.02 accepts a slash and a back-slash between
domain name and userid, Mozilla only accepts a back-slash "\".
(Assignee)

Comment 7

15 years ago
Klaus: very interesting!  i think i understand why there is a difference.  with
Mozilla 1.4, "domain\user" will be parsed to extract the domain and the user
separately for use when NTLM authentication is required.  however, if the server
issues a Basic auth challenge, then the "domain\user" or "domain/user" will be
treated as the entire username to be sent over to the server.  in older version
of mozilla (and derivatives such as Netscape 7.02), there was no support for
NTLM.  probably your firewall accepts both NTLM and Basic authentication.  since
NTLM is more secure than Basic auth, more recent Mozilla builds will choose NTLM
over Basic.  however, older versions would only choose Basic.  i'm guessing that
the proxy server accepts either "domain\user" or "domain/user" as valid Basic
auth usernames.  now, this all means that this bug could be marked INVALID or
WONTFIX unless we decide that Mozilla should treat "domain/user" as
"domain\user"... it probably just depends on what MS IE does.
Severity: major → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
Summary: no Access after Firewall / Proxy → mozilla should? accept forward slash as delimiter between "domain" and "user" [was: no Access after Firewall / Proxy]
Whiteboard: [ntlm-auth] [possibly WONTFIX]
Target Milestone: --- → Future
bug 214599 is the same bug...
(Assignee)

Comment 9

15 years ago
thanks matti... marking this as a duplicate.  this problem should go away once
we have a full NTLM prompt with separate fields for domain, username, and
password.  see bug 199674.

*** This bug has been marked as a duplicate of 214599 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.