Closed Bug 215966 Opened 18 years ago Closed 18 years ago

keyboard focus stolen by tab loaded up in background

Categories

(Firefox :: General, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 124750

People

(Reporter: rfine, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030702 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030702 Mozilla Firebird/0.6

When loading a page containing a text box, Firebird automatically puts the
keyboard focus on the first text box in the page.

However, if I direct two tabs to load up seperate pages, am looking over the
first tab and the second one loads up with a text box, the keyboard focus will
be stolen by the (at the time invisible) box on the second tab.

Reproducible: Always

Steps to Reproduce:
(Note: this will not work very well if pages load instantly for you)
1. Open two tabs.
2. Direct the first tab to a page with a text box (e.g. google). Wait for it to
load.
4. Direct the second tab to another page with a form (e.g. mail.lycos.com).
Quickly switch back to the first tab and begin typing in the text box.
5. When the second tab has finished loading, the keyboard focus should have been
 stolen by the second page (type something, witness that it does not appear in
the box on the first page, and then switch to the second page to see that it's
there instead).
Actual Results:  
The text I typed into the box on the first tab had ended up in the box on the
second tab (i.e. the keyboard focus had been stolen).

Expected Results:  
The text box on the first page should not have lost the focus.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.