The default bug view has changed. See this FAQ.

se-linux.ifs.tuwien.ac.at - Crash when clicking on any rpm links to download an rpm file.

RESOLVED WONTFIX

Status

Tech Evangelism Graveyard
German
--
critical
RESOLVED WONTFIX
14 years ago
2 years ago

People

(Reporter: Zoran Spasojevic, Unassigned)

Tracking

({crash})

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

The firbird 0.6.1 crashes as soon as I click on any links to download an rpm file.
I don't thik the problem existed with firebird 0.6.0 and does not exist with
mozilla 1.4. The problem seems to occure on many rpm depository sites.

Reproducible: Always

Steps to Reproduce:
1.Just go to the web-site above and click on any rpm links.
2.
3.

Actual Results:  
The browser crashes (the window disappears) and I have to restart it.

Expected Results:  
Open a download window and ask where to save the file.

The problem does not seem to be related to themes.

Comment 1

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030826 Mozilla
Firebird/0.6.1+
I cannot reproduce this bug.
Please try to reproduce the bug with latest nightly-build.
http://ftp.mozilla.org/pub/firebird/nightly/latest-trunk/

Comment 2

14 years ago
I can confirm this bug using mozilla 1.4 on RedHat 8. The crash is because the 
rpm file is associated to the realplayer plugin - rpnp.so, but actually, it's 
not.

Raina, hava you installed the realplayer plugin in your linux box?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago
Since this is a plugin bug, changing Product & Component...
Component: Downloading → Plug-ins
Product: Firebird → Browser
Version: unspecified → Trunk

Comment 4

14 years ago
reassign to the default owner.
Assignee: blake → peterlubczynski-bugs
QA Contact: asa → bmartin

Updated

14 years ago
Keywords: crash

Comment 5

13 years ago
The realplayer plugin doesn't work with Mozilla (at all, as far as I can tell).

==> Tech Evang
the server needs to deliver the RPMs with the proper mime time.
Assignee: peterlubczynski-bugs → german
Component: Plug-ins → German
Product: Browser → Tech Evangelism
QA Contact: bmartin → german
Summary: Crash when clicking on any rpm links to download an rpm file. → se-linux.ifs.tuwien.ac.at - Crash when clicking on any rpm links to download an rpm file.
Version: Trunk → unspecified

Comment 6

13 years ago
rpm is also a valid suffix for realplayer media, while it's popular in Linux
world as Redhat package. This is neither a mozilla bug nor a webserver bug (you
can expect webserver can parse the format of each file before sending them out).
This is a realplayer plugin bug, it should be able to parse whether the input is
a valid realplayer format. A bug was filed against this in realplayer community.

https://helix-dna.helixcommunity.org/issues/show_bug.cgi?id=949
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.