octeams.com - binary files served as text/plain

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Mikko Virkkilä, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Browser crashed.

Reproducible: Always

Steps to Reproduce:
1. Go to http://overclockix.octeams.com/
2. Click on link (http://overclockix.octeams.com/Overclockix_ColdFusion.iso)


Actual Results:  
At first it looked like it was opening this binary file in the browser window,
but then it crashed, taking mozilla mail with it.

Expected Results:  
A Save file dialog should pop up and ask me where I want to save the file.

Comment 1

15 years ago
It is trying to open it in the window, because the server incorrectly says that
the MIME type is text/plain.  You should write to the site and ask them to fix
their server setting.
->TE
Assignee: general → english-us
Severity: critical → normal
Component: Browser-General → English US
OS: Linux → All
Product: Browser → Tech Evangelism
QA Contact: general → english-us
Hardware: PC → All
Summary: Browser crashed when opening large file → octeams.com - ISO file served as text/plain
Version: Trunk → unspecified
(Reporter)

Comment 2

15 years ago
But I don't think this should cause the browser to crash. 

I've seen this several times, the browser opening something binary since the
mimetype is wrong, but this is the first time I've seen the browser crash.
Shouldn't we be able to handle all kind of input without a crash?
(Reporter)

Updated

15 years ago
Summary: octeams.com - ISO file served as text/plain → octeams.com - ISO file served as text/plain --> crashes browser

Comment 3

15 years ago
Can you get a stack or Talkback ID for this? I don't have time at the moment to
crash ;-), but this should be a browser bug for the crash and an evang bug for
the mime type on the site.
(Reporter)

Comment 4

14 years ago
I can't reproduce the crash anymore since the iso has changed (they still serve
the files as text/plain though).

I will change the summary to represent the current state of the bug, since it's
now a pure evangelism bug.
Summary: octeams.com - ISO file served as text/plain --> crashes browser → octeams.com - ISOs served as text/plain
(Reporter)

Comment 5

14 years ago
Also the torrents are served as text/plain.
Summary: octeams.com - ISOs served as text/plain → octeams.com - binary files served as text/plain
(Reporter)

Comment 6

13 years ago
No longer serving isos. Closing.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.