Stylesheets not loaded from virtual host

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Paul Hensel, Assigned: dbaron)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030806 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030806 Mozilla Firebird/0.6.1+

This page relies on an external style sheet in the same directory (style2.css).
 When the page is loaded from its conventional location
(http://www.fsu.edu/~broward/index2.html), the style sheet loads correctly. 
When the page is loaded from its virtual host
(http://www.broward.fsu.edu/index2.html), though,the style sheet fails to load.  

This happens with every Gecko-based browser I have tried (Camino 0.7, Mozilla
1.5a, and Firebird 0.6.1/nightlies) -- but it works fine with both IE 5.2.3 and
Safari 1.0, both of which load the style sheet correctly from either version of
the URL.  The problem can be worked around (so that it works in all five of
these browsers) by using an absolute reference to the style sheet
(http://www.fsu.edu/~broward/style2.css) rather than simply linking to
style2.css; I've used this workaround to fix the other pages on this site, but
I've left this one test page in its current state to help diagnose the problem.
 The style sheet still fails to load if it is referenced with an absolute link
to the virtual host, though (http://www.broward.fsu.edu/style2.css).  

This is how our Web guys explained the virtual host to me when I was trying to
figure out this problem:  "The virtual host is actually on mailer.fsu.edu, a
separate computer from www.fsu.edu.  The documentroot points to the public_html
directory for the ~broward account, which is NFS mounted on mailer."

My apologies if this is the wrong component for this bug -- it may not really be
a Style System bug, because the style sheet doesn't load in the first place.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL listed above.
2. Observe the web page.

Actual Results:  
The page loads without the external style sheet, so it appears as regular text
(black text and the browser's default colors for links) on the left side of the
page against a white background.

Expected Results:  
The page should load with the external style sheet.  The page title should
appear as gold text against a garnet/red background, the navigation box should
appear as garnet text against a tan background, and content should appear as
black text (and garnet links) against a white background.
Tools/web Development/JS Console:

Error: The stylesheet http://www.broward.fsu.edu/style2.css was not loaded
because its MIME type, "text/plain", is not "text/css".


Your server sends the wrong mime-type for this css -> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.