Closed Bug 21607 Opened 20 years ago Closed 20 years ago

[DOGFOOD]Crashed when trying to send message to 3.5 News Server Newsgroup

Categories

(MailNews Core :: Networking, defect, P3, critical)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: huang, Assigned: sspitzer)

References

Details

(Whiteboard: [PDT+] Verified fix.)

WinNT12-13-09-M12:

Actual Results:
Crashed when trying to send message to 3.5 News Server Newsgroup:"junk".
3.5 news server name: poisonivy (default port:119)

Expected Results:
Shouldn't crash when trying to send message to 3.5 News Server Newsgroup:"junk".

Two talkbacks as following:

Talkback#2369349:
MSVCRT.dll + 0x1230 (0x78001230)
MSVCRT.dll + 0x140e (0x7800140e)
nsStdURL::Parse [d:\builds\seamonkey\mozilla\netwerk\base\src\nsStdURL.cpp, line
307]
nsStdURL::SetSpec [d:\builds\seamonkey\mozilla\netwerk\base\src\nsStdURL.cpp,
line 1232]
nsNntpService::PostMessageA
[d:\builds\seamonkey\mozilla\mailnews\news\src\nsNntpService.cpp, line 652]
nsMsgComposeAndSend::DeliverFileAsNews
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line
2546]
nsMsgComposeAndSend::DeliverMessage
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line
2389]
nsMsgComposeAndSend::GatherMimeAttachments
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 971]
nsMsgComposeAndSend::HackAttachments
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line
2016]
nsMsgComposeAndSend::Init
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 2300]
nsMsgComposeAndSend::CreateAndSendMessage
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 3008]
nsMsgCompose::_SendMsg
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCompose.cpp, line 563]
nsMsgCompose::SendMsg
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCompose.cpp, line 640]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 139]
nsXPCWrappedNativeClass::CallWrappedMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativeclass.cpp,
line 895]
WrappedNative_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 192]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 666]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2227]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 686]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2227]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 686]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2227]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 686]
js_InternalCall [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 759]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2754]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 551]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 129]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
654]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
793]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 2675]
nsEventStateManager::CheckForAndDispatchClick
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
1368]
nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
560]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2617]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 841]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1678]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 425]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 442]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3334]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3550]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2646]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 609]
USER32.dll + 0x1820 (0x77e71820)

talkback#2369549:
MSVCRT.dll + 0x1227 (0x78001227)
MSVCRT.dll + 0x140e (0x7800140e)
nsStdURL::SetSpec [d:\builds\seamonkey\mozilla\netwerk\base\src\nsStdURL.cpp,
line 1232]
nsNntpService::PostMessageA
[d:\builds\seamonkey\mozilla\mailnews\news\src\nsNntpService.cpp, line 652]
nsMsgComposeAndSend::DeliverFileAsNews
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line
2546]
nsMsgComposeAndSend::DeliverMessage
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line
2389]
nsMsgComposeAndSend::GatherMimeAttachments
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 971]
nsMsgComposeAndSend::HackAttachments
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line
2016]
nsMsgComposeAndSend::Init
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 2300]
nsMsgComposeAndSend::CreateAndSendMessage
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgSend.cpp, line 3008]
nsMsgCompose::_SendMsg
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCompose.cpp, line 563]
nsMsgCompose::SendMsg
[d:\builds\seamonkey\mozilla\mailnews\compose\src\nsMsgCompose.cpp, line 640]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 139]
nsXPCWrappedNativeClass::CallWrappedMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativeclass.cpp,
line 895]
WrappedNative_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 192]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 666]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2227]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 686]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2227]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 686]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2227]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 686]
js_InternalCall [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 759]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2754]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 551]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 129]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
654]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
793]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 2675]
nsEventStateManager::CheckForAndDispatchClick
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
1368]
nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
560]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2617]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 841]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1678]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 425]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 442]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3334]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3550]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2646]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 609]
USER32.dll + 0x1820 (0x77e71820)
Didn't get crash for Linux,
but got the following error message when trying to send message from the 3.5
news server's newsgroup: "junk" for the Linux platform:

'A News (NNTP) error occured: Postings to "junk" are not allowed here'

Already tried on 4.7 -> sent message from the 3.5 news server's newsgroup"junk"
successfully without the crash and error.
Also tried on Mac build 12-13-08-M12 -> same result as Linux build:
Got an error message:
'A News (NNTP) error occured: Postings to "junk" are not allowed here'
After click 'OK' -> got another error: 'Sending of message failed',
after click 'OK' will go back to the compose window and leave compose window
opened.
The message which Karen is seeing about postings not being allowed in the junk
group is likely happening because the posting is really being delivered to
news.mozilla.org instead of poisionivy.  (The junk newsgroup on news.mozilla.org
is reserved for a special use.)  So, there is some other problem(s) underlying
here for further investigation.
Yes. After talked to Laurel, I tried on the new profile and used account wizard
for creating New news  account and subscribed the "junk" newsgroup again.
I got the different results:
It used to crash on WinNT by using the migrated profile -> but I got the other
error message:"[StringID(hex)=8000ffff?]" when I used new profile.
Additional info after discussed with Laurel.
My news [default] from 4.7 was: news.mozilla.org.
For some reason, the 5.0 is always trying to pickup the default news' newsgroup
(ex: junk), so that's why the error 'A News (NNTP) error occured: Postings to
"junk" are not allowed here' came from the default (Laurel & I are guessing...)
I am trying to narrow down for this problem...I think that I need to do more
investigation on this bug....(Thanks Laurel for providing more information to
me!!)
Status: NEW → ASSIGNED
Summary: Crashed when trying to send message to 3.5 News Server Newsgroup → [DOGFOOD]Crashed when trying to send message to 3.5 News Server Newsgroup
Target Milestone: M13
yikes, crashing.

will look into this tomorrow.
Whiteboard: [PDT+]
[PDT+]
I'm not seeing the crash on windows or linux.

I do see two problems:

1) on windows I get the [StringID(hex)=8000ffff?] error dialog, and that is bad,
and I'll look into that.

2) I really need to finish the code that correctly determines which host to post
to.  there have been too many duplicates of #17655

tommorrow, if I don't crash with a new profile or a migrate profile, I'm going
to change this bug and not make it dogfood.
I had crashed for yesterday 12-16-12-M12 WinNT commercial build. Maybe related
to bug#22001
*** Bug 22035 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
QA Contact: lchiang → huang
Change QA contact to me, Cc: Lisa.
Status: RESOLVED → VERIFIED
Whiteboard: [PDT+] → [PDT+] Verified fix.
Verified on the WinNT 2000-01-03-09-M13 commercial build:
I can post the news message now for the 3.5 News Server for existing profiles
and new profiles. It work for the junk, karen...etc newsgroups now.
I also verified on the other news servers (See bug#17655) and they are all
working fine now. Updating Status Whiteboard & Marking as verified!!
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.