CERT_NameToAscii fails with too-long attribute

RESOLVED DUPLICATE of bug 220855

Status

NSS
Libraries
RESOLVED DUPLICATE of bug 220855
15 years ago
15 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Assigned: Wan-Teh Chang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

NIST's new test suite has some certs with UTF8 encoded components in the 
subject names.  For one of them, NSS seems unable to translate the DER
subject name to an ASCII string.  This is apparently a failure of
CERT_NameToAscii.  It shows up in programs like pp or vfychain when they
attempt to print the cert's subject name.  

I will attach the offending cert
(Reporter)

Comment 1

15 years ago
Created attachment 129778 [details]
cert that exhibits the problem (binary)
(Reporter)

Comment 2

15 years ago
The problem is that the CommonName in the cert's subjcet name exceeds 
the maximum permitted length, which is 64 characters.
There is a separate bug about that.

*** This bug has been marked as a duplicate of 220855 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
Changed summary to describe the real problem
Summary: CERT_NameToAscii fails for cert with UTF8 subject name → CERT_NameToAscii fails with too-long attribute
You need to log in before you can comment on or make changes to this bug.