Closed Bug 216137 Opened 21 years ago Closed 21 years ago

Make xpinstall/packager produce thunderbird/Firebird packages

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: davidf, Assigned: mscott)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030807 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030807 Mozilla Firebird/0.6.1+

In mozilla, you can do a Make in xpinstall/packages which produces a mozilla tar
file. However, this assumes that the name of the executable is mozilla-bin. This
should be changed so the name is taken from the MOZ_PKG_APPNAME setting

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Attaching a patch for xpinstall/packager/Makefile.in, which allows building a
thunderbird package by running
MOZ_PKG_NAME=thunderbird make
in the xpinstall/packager directory.
you should move this to mozilla / xpinstall and ask those folks to look at it.
it really isn't a thunderbird issue.
Thanks, scott. Moving to Browser.
Component: Build Config → Installer: XPInstall Engine
Product: Thunderbird → Browser
Version: unspecified → Trunk
Comment on attachment 129787 [details] [diff] [review]
patch to allow building thunderbird install package

this is a RFE to allow building a thunderbird install package by doing a Make
in xpinstall/packages. I have attached a working patch which fixes the problem
by replacing "mozila" with "$(MOZ_PKG_APPNAME)" where required. Tested and
works
Attachment #129787 - Flags: review+
Comment on attachment 129787 [details] [diff] [review]
patch to allow building thunderbird install package

sorry, marked wrong flags ... setting review, superreview to ?
Attachment #129787 - Flags: superreview?
Attachment #129787 - Flags: review?
Attachment #129787 - Flags: review+
QA Contact: asa
Attachment #129787 - Flags: superreview?(mscott)
Attachment #129787 - Flags: superreview?
Attachment #129787 - Flags: review?(dveditz+bmo)
Attachment #129787 - Flags: review?
Comment on attachment 129787 [details] [diff] [review]
patch to allow building thunderbird install package

I misunderstood this bug the first time around. This looks ok to me.
Attachment #129787 - Flags: superreview?(mscott) → superreview+
Comment on attachment 129787 [details] [diff] [review]
patch to allow building thunderbird install package

beautiful
Attachment #129787 - Flags: review?(dveditz+bmo) → review+
Summary: Make xpinstall/packager produce thunderbird packages → Make xpinstall/packager produce thunderbird/Firebird packages
*** Bug 173770 has been marked as a duplicate of this bug. ***
checked in.
Fixed by checkin from pch.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: