height of opened window does not correspond height given in parameter

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Sander Van de Moortel, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030718

I have this php script which checks for the height and width of an image and
automaticalle fills in the parameters for window.open so the picture fits in it
more or less.

I do $imageheight+90 and $imagewidth+20, so the additional text is visible. But
at times, when opening a picture with width bigger than height, the opened
window will have a height which is way too large for the picture.

Besides there's some difference between IE and Mozilla in handling the height.

Reproducible: Always

Steps to Reproduce:
1. Go to the site
2. Go to any album (i.e. testalbum)
3. Open any picture: compare the dimension of the opened window when opening
landscape pictures and portrait pictures.

Actual Results:  
dimension too large with landscape pics

Expected Results:  
respect my parameters! (and not grin at me while doing it all wrong again)

this bug has occurred ever since I've been working with mozilla, which should be
since 1.0alpha?

Comment 1

15 years ago
An example from the site:
window.open('foto_show.php?id=4','4','width=662 height=547 scrollbars=no')

Try using comma as separator in the last parameter, like so:
window.open('foto_show.php?id=4','4','width=662,height=547,scrollbars=no')
OS: Windows XP → All
(Reporter)

Comment 2

15 years ago
Hey thanks, this works indeed, but surely the javascript syntax doesn't 
require the usage of commas, or does it?

Comment 3

15 years ago
I think it is required, see:
http://msdn.microsoft.com/workshop/author/dhtml/reference/methods/open_0.asp
and
http://mozilla.org/docs/dom/domref/dom_window_ref76.html#1019331

They both say it should be a comma-separated list.


-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.