background image in mail not sent embedded, only the URL is sent.

RESOLVED DUPLICATE of bug 116867

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 116867
15 years ago
13 years ago

People

(Reporter: Karsten Isakovic, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.5a/mozilla-win32-1.5a-installer-sea.exe

If i compose a message containing an background image which is stored on my 
local harddisc and sent it (or store it as draft) only the url is embedded and 
not the image data. The body tag in the html data has another format now (using 
style="background-image: url(localfilename)") than in version 1.4, that used 
the background="msgid-...." tag.

Reproducible: Always

Steps to Reproduce:
1.Compose message (even to oneself), no subject or text needed
2.Format/page colors and background, choose file, image is displayed in 
background
3.Send or save as draft
4.Open drafts folder (or freshly arrived message), select message, view/Message 
source
5.The body html tag has a style attribute tag that contains a background-image: 
url(....) . The url points to the local drive, image data is not embedded into 
the mail.


Actual Results:  
The background image is not sent and therefor the message is not displayed 
correctly for the recipient.

Expected Results:  
The older versions of modzilla did not use the style=".... background-image:url
(xxx)" method, they used the html tag background="msg-id" and added the image-
data to the message.

I looked up the help files and checked my preferences. But i didnt find 
anything relevant to send the images together with the message. Or how to 
switch back to the old message style not using ccs (i assume thats where the 
style-attribute tag comes from ?)


Including images directly into the message still works, the data is send and 
encoded into the message.  

I switched back to version 1.4, which does not have this problem.
Reporter: I believe this has been fixed in yesterdays Thunderbird build, located
at <http://ftp.mozilla.org/pub/thunderbird/nightly/2003-08-13-trunk/>.
However, it seems to be a dupe of bug 116867. If you don't agree, please reopen
this, stating why.

*** This bug has been marked as a duplicate of 116867 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.