implement CTRL-{SHIFT}-TAB to cycle browser frames, (similar mailnews)

VERIFIED WORKSFORME

Status

()

--
enhancement
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: stefan, Assigned: aaronlev)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030718
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030718


an enhancement, not a bug. I use keyboard navigation only, and I like the way
that   CTRL-TAB /CTRL-SHIFT-TAB is used in mailnews to cycle through the
different mail panes. I've been habituated into re-apply the motion on websites
with frames (like google news), where shifting the focus to the other frame
usually means TABbing through a large number of links in the first frame.

currently CTRL-TAB cycles through tabs if you're using tabbed browsing, and that
is also logical (and OS consistent behaviour), so if tabbed browsing is in
effect, could it be made to cycle into the frames on a particular tab (if that
tab contains frames), and behave as is if there are no frames, or as mailnews if
there are no tabs.

I'll try and make that clearer.

case: browser tabs open, no tabs contain frames

function of CTRL-TAB: as now.

case: no tabbed browsing, page contains no frames

CTRL-TAB: no action

case: no tabbed browsing, page contains frames

CTRL-TAB: cycle focus through the frames

case: tabbed browsing, a tab contains frames

CTRL-TAB: if (current tab contains frames, select next frame)
          if (current frame is last frame of frameset, select next tab)
          else select next tab

I think that's it.




Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
Use F6, Shift+F6.

IIRC, some time ago it was done with Ctrl+Tab, but due to the use of tabbed
browsing and the little number of pages with frames it was changed this way.

this is WFM.
(Reporter)

Comment 2

16 years ago
Yep, that's perfect. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 3

16 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.