Move sidebars database to mozilla.org

RESOLVED DUPLICATE of bug 49367

Status

mozilla.org
Miscellaneous
--
enhancement
RESOLVED DUPLICATE of bug 49367
15 years ago
15 years ago

People

(Reporter: Met - Martin Hassman, Assigned: Mitchell Baker)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.4) Gecko/20030624

Only enhancement request.

The sidebars database is now on http://sidebar-rdf.netscape.com/ but it seems
not changing for a long time. Maybe nobody is managing it. And there is not much
sidebars. We was not able to add 40 Czech sidebars there.

Why do not move the database to the mozilla.org?
When someone will managing it the database can grow quickly, there are many
sidebars, which are not in the Netscape database.
And this is sad.

If we want to popularize sidebars make sidebars database for users as large as
can be.

Reproducible: Always

Steps to Reproduce:
This bug does not belong in Browser->Sidebar. Perhaps mozilla.org->Misc ?

I agree that the sidebar page at netscape should be moved to a place where it
will be maintained. Perhaps mozillazine.org or mozdev.org would be better ?

Have you tried contacting people there ?

Or you could start your own mozdev.org project (like
<http://extensionroom.mozdev.org/>). Or find somebody else who will.
Summary: Move sidebars database to the *.mozilla.org → Move sidebars database to mozilla.org

Updated

15 years ago
Summary: Move sidebars database to mozilla.org → Move sidebars database to the *.mozilla.org

Comment 2

15 years ago
-> Mozilla.org/Misc
Assignee: shliang → mitchell
Component: Sidebar → Miscellaneous
Product: Browser → mozilla.org
QA Contact: sujay → mitchell
Summary: Move sidebars database to the *.mozilla.org → Move sidebars database to mozilla.org
Version: Trunk → other

Comment 3

15 years ago
URL not working. where's the db now?

Comment 4

15 years ago
All the links are broken at http://dmoz.org/Netscape/Sidebar/, which is where
you are sent when you choose to add new ones in the sidebar. See bug #214819.

The best long-term fix for that is to fix this one.
Blocks: 214819
Can someone outline what the sidebar database actually does, who consults it
(people? programs?) and what mozilla.org would need to do and change to host it?

Gerv
(Reporter)

Comment 6

15 years ago
I¦prefs¦are¦3¦sidebar¦related¦URLs:
pref("sidebar.customize.all_panels.url",
"http://sidebar-rdf.netscape.com/%LOCALE%/sidebar-rdf/%SIDEBAR_VERSION%/all-panels.rdf");
pref("sidebar.customize.directory.url",¦"http://dmoz.org/Netscape/Sidebar/");
pref("sidebar.customize.more_panels.url",¦"http://dmoz.org/Netscape/Sidebar/");¦

For¦example¦in¦the¦Czech¦Mozilla¦localization¦URLs¦are:
pref("sidebar.customize.all_panels.url",
"http://www.czilla.cz/sidebars/panels/all-panels.rdf");
pref("sidebar.customize.directory.url",¦"http://www.czilla.cz/sidebars/");
pref("sidebar.customize.more_panels.url",¦"http://www.czilla.cz/sidebars/");
¦
The¦first¦is¦URL¦of¦the¦RDF¦root¦for¦the¦sidebars¦database¦(used¦for¦the
browsing¦in¦the¦Sidebar/Tabs/Customize¦sidebar¦->¦Available¦tabs),¦the¦others¦(I
don't¦know,¦what¦is¦the¦difference¦betweeen¦sidebar.customize.directory.url¦and
sidebar.customize.more_panels.url)¦should¦point¦at¦the¦HTML¦version¦of¦the
sidebars¦database.

Mozilla.org¦should¦create¦e.g.¦http://mozilla.org/sidebar/all-panels.rdf¦(good
idea¦is¦generate¦*.rdf¦files¦dynamically¦from¦some¦database)¦with¦main
categories¦(look¦e.g.¦at¦http://www.czilla.cz/sidebars/panels/all-panels.rdf¦for
file¦example)¦and¦the¦HTML¦version¦e.g.¦http://mozilla.org/sidebar/index.html

My¦proposal¦is¦to¦put¦the¦main¦EN¦categories¦in¦root¦and¦in¦the¦subfolder¦e.g.
"International¦sidebars"¦should¦point¦to¦the¦non-english¦sidebars¦-¦these¦may¦be
hosted¦on¦different¦servers,¦so¦mozilla.org¦will¦maintain¦only¦English¦sidebars
and¦pointing¦to¦local¦Mozilla¦groups¦which¦will¦maintain¦sidebars¦in¦their
languages¦(localized¦Mozilla's¦may¦point¦to¦their¦local¦database¦as¦root¦folder
and¦have¦EN¦and¦other¦sidebars¦in¦the¦subfolder¦-¦so¦this¦is¦in¦the¦CZech
Mozilla¦version¦now).
Summary: Move sidebars database to mozilla.org → Move¦sidebars¦database¦to¦mozilla.org
I'm not even going to ask what that gibberish is.  Someone's browser got the
charset confused I think.
Summary: Move¦sidebars¦database¦to¦mozilla.org → Move sidebars database to mozilla.org
(Reporter)

Comment 8

15 years ago
(In reply to comment #7)
> I'm not even going to ask what that gibberish is.

I am sorry, I don't know, why this happened. So once more:

In prefs are 3 sidebar related URLs:
pref("sidebar.customize.all_panels.url",
"http://sidebar-rdf.netscape.com/%LOCALE%/sidebar-rdf/%SIDEBAR_VERSION%/all-panels.rdf");
pref("sidebar.customize.directory.url", "http://dmoz.org/Netscape/Sidebar/");
pref("sidebar.customize.more_panels.url", "http://dmoz.org/Netscape/Sidebar/"); 

For example in the Czech Mozilla localization URLs are:
pref("sidebar.customize.all_panels.url",
"http://www.czilla.cz/sidebars/panels/all-panels.rdf");
pref("sidebar.customize.directory.url", "http://www.czilla.cz/sidebars/");
pref("sidebar.customize.more_panels.url", "http://www.czilla.cz/sidebars/");
 
The first is URL of the RDF root for the sidebars database (used for the
browsing in the Sidebar/Tabs/Customize sidebar -> Available tabs), the others (I
don't know, what is the difference betweeen sidebar.customize.directory.url and
sidebar.customize.more_panels.url) should point at the HTML version of the
sidebars database.

Mozilla.org should create e.g. http://mozilla.org/sidebar/all-panels.rdf (good
idea is generate *.rdf files dynamically from some database) with main
categories (look e.g. at http://www.czilla.cz/sidebars/panels/all-panels.rdf for
file example) and the HTML version e.g. http://mozilla.org/sidebar/index.html

My proposal is to put the main EN categories in root and in the subfolder e.g.
"International sidebars" should point to the non-english sidebars - these may be
hosted on different servers, so mozilla.org will maintain only English sidebars
and pointing to local Mozilla groups which will maintain sidebars in their
languages (localized Mozilla's may point to their local database as root folder
and have EN and other sidebars in the subfolder - so this is in the CZech
Mozilla version now).

Comment 9

15 years ago

*** This bug has been marked as a duplicate of 49367 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
No longer blocks: 214819
You need to log in before you can comment on or make changes to this bug.