Empty toolbar shown in popup if webpage hides all the toolbar's items

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
--
trivial
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Minh Nguyễn, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

If a webpage uses JavaScript to open a popup window without the Location bar,
and the user has created a toolbar that contains only the Location bar, the
popup window will still display the empty toolbar. This is a trivial bug; only a
slight loss of screen real estate and an annoyance for those who can't stand the
waste of such real estate.

Reproducible: Always

Steps to Reproduce:
1. Go to View | Toolbars | Customize...
2. Create a new toolbar.
3. In it, place only the Location Bar.
4. Click Done.
5. Go to a website that uses JavaScript to open popup windows without the
Location Bar, such as http://weblogs.mozillazine.org/asa/
6. Click on the link that generates the popup window. In Asa's blog's case,
click on one of the Comments links.

The same results occur if you replace each occurrence of "Location Bar" with
"Search Bar". Some other websites that you can observe this behavior on are
Netscape WebMail, Netscape Address Book (the one on Netscape.com), and many
weblogs powered by Movable Type or TypePad. (MT's default templates create such
popup windows)

Actual Results:  
The new toolbar was displayed, empty.

Expected Results:  
Firebird should have hidden the new toolbar, since it would've been empty anyways.

Comment 1

14 years ago
This works for me with the 20030907 build on Windows 2000.

Your build is already rather old (over one month) and a lot has happened since 
then regarding firebird development. Please read 
http://texturizer.net/firebird/bugs.html before reporting any bugs.

I'm resolving this as WORKSFORME. Please reopen this bug, if you still see this 
with a current nightly build, a fresh profile and without any additional themes or 
extensions. Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.