adding a new calander makes the new calendar copy all active calendars notes to new calendar.

RESOLVED WORKSFORME

Status

Calendar
General
--
major
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: k b, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030812
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030812

having at one calendar active. then creating a new calendar that resides on a
server, not filling in the Location of the local file, the calendar will name
the new calendar as the the old. this will look like you have two calendars, but
when you edit you might destry other data.

this also seems to happen when selecting "subscribe to remote calendar"

Reproducible: Always

Steps to Reproduce:
1. have one calendar (with events) active.
2. right click the active calendar and select Edit Calendar.
3. Look up the file name in the Location (local) field; it says something like:
...../CalendarDataFile1.ics
4. now create a new calendar that resides on a server, do not fill in the
Location field for local file.
5. Now right click the new calendar and select Edit Calendar.
6. Look up the name of the local Location file, it says CalendarDataFile1.ics
Actual Results:  
calendar using wrong local file, it should not use the same file for both calendars.

Expected Results:  
should not copy name, instead it sould create a file that does not already exist.

Comment 1

14 years ago
This one works for me, marking accordingly.

Reporter:
Please try a current xpi. If the problem persists, add a comment here and I'll
reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.