Tab switch blocked on untitled tab after page could not be found

VERIFIED DUPLICATE of bug 227887

Status

()

Firefox
Toolbars and Customization
--
minor
VERIFIED DUPLICATE of bug 227887
15 years ago
12 years ago

People

(Reporter: mozilla, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Create a new tab by Ctrl-clicking a link. Assume the link's target page cannot
be reached and the error message is popped: "www.somepage.com cannot be found.
Please check the name and try again". Subsequently the new blank tab, titled
"(untitled)", can be switched to using Ctrl-PageUp/Down or Ctrl-(Shift-)Tab, but
(and this is the bug) cannot be switched away from. 

Reproducible: Always

Steps to Reproduce:
1. See "Details"
2.
3.

Actual Results:  
When flipping through the tabs using the shortcut keys, the "(untitled)" tabs
have become switch traps. You can switch to them, but not away.

Expected Results:  
Just switch on to the next tab. Or maybe the "page cannot be found" error should
result in the new tab to be cancelled and removed.

Updated

15 years ago
QA Contact: asa

Comment 1

15 years ago
Can you retest with a trunk nightly from
http://ftp.mozilla.org/pub/mozilla.org/firebird/nightly/latest-trunk/?  This
might have been fixed by aaronl's checkin to bug 192729.

Comment 2

15 years ago
Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a)
Gecko/20040131 Firebird/0.8.0+

Happens only in Firebird, not on Seamonkey. Must be a bug in our tabbrowser code.
Assignee: blake → hyatt
Status: UNCONFIRMED → NEW
Component: General → Toolbars
Ever confirmed: true
QA Contact: bugzilla

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 227887 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
verified duplicate
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.