using a scrollbar on a layer fires an unwanted onMouseOut event.

RESOLVED DUPLICATE of bug 157305

Status

()

RESOLVED DUPLICATE of bug 157305
15 years ago
15 years ago

People

(Reporter: robbie, Assigned: saari)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

As soon as your cursor enters a scrollbar of a div with 'overflow: auto' 
or 'overflow: scroll' an onMouseOut event is fired. In this example the layer 
will disappear. One might expect the scrollbar to be a part of the layer and 
not generate an onMouseOut event when trying to use the scrollbar.

Reproducible: Always

Steps to Reproduce:
1.Look at http://www.romeen.nl/csstest.html
2.Try to scroll this layer.
3.

Actual Results:  
an onMouseOut event gets executed

Expected Results:  
an onMouseOut event should not get executed.

*** This bug has been marked as a duplicate of 157305 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.