Firefox stops responding to keyboard/mouse input

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
critical
VERIFIED INCOMPLETE
15 years ago
7 years ago

People

(Reporter: jeff putnam, Unassigned)

Tracking

unspecified
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3.5 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

At random times firebird stops responding to keyboard/mouse input.  

This usually seems to happen when I'm trying to type into the url bar so it may
be focus related however once firebird enters this state, it hangs completely. 
No keyboard input is accepted nor is any mouse input.  Minimizing and
redisplaying the browser results in correct redisplay, but no user input is
accepted.  The browser must then be killed by hand. 

Simple tests like switching windows (or switching desktops) seem to make no
difference.  

I have tab extensions and radial context installed.  

Reproducible: Sometimes

Steps to Reproduce:
1. Start browsing.
2. Switch to url bar to type/change a url.
3. Repeat until browser hangs.   Eventually firebird pretty much always hangs
when I do this, but how long it takes varies from a few minutes to a few hours.   
Actual Results:  
Browser hangs.  Does not accept keyboard/mouse input. 

Expected Results:  
Not hang. 

Linux - several releases of linux do the same thing.  I dont use windows often
enough to know if it occurs there.  

Tab extensions and readial context installed.

Comment 1

15 years ago
Extensions may cause weird behaviour. Can you please try this with a current
nightly build and a fresh profile without any extensions.
URL: (many) (many)
Summary: firebird stops responding to keyboard/mouse input → firebird stops responding to keyboard/mouse input

Comment 2

15 years ago
I also have the same bug in all the LAST (source, binary or cvs) version of
firebird and mozilla !!!
when i touch a key, the browser freeze.

I try to create a new user, but no difference

Updated

15 years ago
QA Contact: asa

Comment 3

15 years ago
Confirming New i am seeing this bug in 20030923 0.7+

My Mouse input stops responding, usually when loading jpegs locally, or Favicons
into bookmarks, Im in Windows 2000, and it doesnt seem as bad as the linux reports
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

15 years ago
I've been unable to reproduce the bug consistently without the extensions, but I
do have some more information that may be of help.  It seems to always occur when 
I'm using tabs and a bit of trying today resulted in noting that it always seems
to occur on a mouse-click-drag motion.  Furthermore, today I've noticed the
following error message in a terminal window - why I've never seen it before I
don't know : 

Gtk-CRITICAL **: file gtkdnd.c: line 623 (gtk_drag_get_data): assertion `widget
!= NULL' failed.

Comment 5

15 years ago
I have the same problem focusing windows sometimes,
keyboard input stop working for address bar and input
however if i click on <file> <edit> <view> <go> or any of those (using mouse)
and input the underlined letter (for example help-> about mozilla i would click
on help and type A) that still works
input doesnt work for a while .. tends to comee back after 2 - 3 minute
please fix :)

Comment 6

15 years ago
Note that bug 165554 and bug 216288 also talks of the GTKDND message followed by
a hang. Related?

Comment 7

15 years ago
All you have to do is view a dialog or some other window on top of your window.
This causes Firebird to stop accepting any keyboard input.

For instance, try typing in the URL mcdonalds://a.jpg, and click OK when the
dialog appears.

The input should now stop working.

Comment 8

15 years ago
Hello all,

I have found this bug running Mozilla 1.4 the latest firebird Mozilla 1.4.1 all
on Linux.  The bug is reproduced consistently and after it is hit, even sending
the TERM signal to the mozilla-bin proccess and reloading mozilla (or firebird)
does not resolv this behaviour.

Could this be a memory leak thing, perhaps Mozilla is not cleaning up after itself.

I would really like to see this bug resolved, does it have anything to do with
gtk+ libs?  It does this on my slackware 9.0 installation but not on Fedora
(test3) on my laptop which is a much more recent release of GNU/Linux.

The command I am using to kill mozilla is 'killall -s TERM mozilla-bin'  I have
tried all the other applicable TERM signals with the same results.

Please advise soon.

Other than that I think your browser absolutely ownz (both mozilla and firebird).

Comment 9

14 years ago
Hi there,

Using the last(?) release Mozilla Firebird 0.7+ Mozilla/5.0(X11;U;Linux
i686;fr;rv:1.5) Gecko/20031007 Firebird/0.7. I've stell a problem with freeze of
keyboard input (mouse always run). It appear always I use CTRL-C/CTRL-V/CTRL-X
to cut/copy/past strings in Firebird or another application before coming
working with Firebird. I must create an another window of Firebird to solve the
problem.

Informations :
Mandrake 9.2
Linux 2.4.22
KDE 3.14
AZERTY keyboard

Hope it helps,

Malo

Comment 10

14 years ago
*** Bug 200041 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
It appears that Mozillia usually hange for me under this bug or crashes under
bug 200056, which would suggest that a common resource is being exhausted.

I have been seeing this as of 1.5b.

Comment 12

14 years ago
I have the same problem when I use laptop internal keyboard. But if I use
external keyboard it seems all OK.

Comment 13

14 years ago
The bug come back.
Àll was rigth since i install OpenOffice.
Then , Firefox 0.8 and mozilla  1.6 freeze again 
Since I upgraded to Firefox 0.9 (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9) I frequently suffer from a problem similar to the
one described in this bug number. Firefox just stops responding to mouse clicks,
although using Firefox trhough the keyboard works fine. Exiting and starting
firefox again makes it work as expected.

I have been unable to find a 100% reproduceable way to make this error happen,
but it usually happens when on one of the tabs is trying to load some URL, and
for whatever reason that remote site is unable to feed Firefox with data. It is
quite annoying :-)

I will try to make some test case or find some URL which triggers this bug
reproduceably and post it here, in the hope it can help.
I have just found that (as of NOW) trying to load the following URL triggers the
bug I described previously. Tried with a clean install of Mozilla Firefox 0.9
(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9)
with no one additional extension added, and with no previous profile o
$HOME/.firefox.

http://www.nic.es

The above URL loads perfectly with Konqueror, but fails to load with Firefox
0.9, and it triggers the bug about Firefox ignoring mouse clicks, and also not
highlighting the menu icons when the cursor is over them.

Hope it helps.

Updated

14 years ago
Blocks: 255525

Updated

14 years ago
Blocks: 250034

Updated

14 years ago
Blocks: 248270

Updated

14 years ago
Blocks: 246974

Comment 16

14 years ago
(In reply to comment #15)

In your case, it's hanging because of a certificate dialog.
It's bug 242275 which is fixed.

Comment 17

13 years ago
This seems to be correlated with browsing Live Bookmarks.

Comment 18

13 years ago
this happens to me too, usually when typing in an applet it allows text in
either the applet or the url bar and text boxes etc. but not both
Summary: firebird stops responding to keyboard/mouse input → Firefox stops responding to keyboard/mouse input

Comment 19

13 years ago
I have two systems running WinXP-SP2 with this bug. -tpettyrox@gmail.com

Comment 20

12 years ago
I am getting this with a new WindowsXPv2 PC Got it with 1.0.7 and also 1.5.beta - though not as badly.  I have no extensions or themes loading.  Usually happens when I have browsed for a minute or 2 .  Its not the line as IE is OK.  The "stop loading " button is greyed ou - and often the page is already greyed out - often the page is loaded and I am just trying to scroll.  Sometimes get the Windows FF is not responding message would you like to send a report to MS message.  I have disabled Adware, firewall etc etc so its a very clean machine.  Thunderbird is working fine 

Comment 21

12 years ago
Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
OS: Fedora Core 4

I also experience the keyboard-not-responding problem (mouse still works).
However, it seems to happen only when firefox is run remotely (through ssh).
Assignee: bross2 → nobody
QA Contact: general

Comment 22

10 years ago
I get this when Firefox is running and I open Microsoft Word 2000.

Comment 23

10 years ago
I get this bug or one like it in Firefox 3.01.  My mouse will let me scroll with the wheel, but the cursor only appears once per page refresh.  I can click once, then the mouse will do nothing on that page until I resize or refresh the page.

Additional info:  It is a generic USB mouse - made by promicro [which doesn't appear to exist!]  No other programs need to be running.  The mouse works fine with FF2.16.
Flags: blocking-firefox3.1?
This seems like its a really generic bug... without specific steps to reproduce its basically impossible to fix it.  We should have one bug per set of STR, and work on each root cause, rather than some generic "this doesn't work sometimes" bug with multiple causes.
Flags: blocking-firefox3.1? → blocking-firefox3.1-

Comment 25

9 years ago
=> incomplete due to no additional information

please see https://developer.mozilla.org/en/Bug_writing_guidelines and file new, individual bugs if needed
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.