Closed Bug 21636 Opened 20 years ago Closed 20 years ago

Cut and Paste Problem

Categories

(SeaMonkey :: General, defect, P3)

HP
HP-UX
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mgleeson1, Assigned: mozilla)

References

Details

1) Keyboard shortcuts for cut and paste (alt-c, alt-v) are not currently
working.

2) middle mouse button no longer recognized.
Blocks: 18687
Status: NEW → ASSIGNED
Target Milestone: M14
Assignee: mgleeson1 → pepper
Status: ASSIGNED → NEW
reassigning to Shane
Status: NEW → ASSIGNED
This seems to be an ongoing thread on the moz unix newsgroup.  I don't think its
only a problem on HP.  I'll ontinue tracking the thread and make sure it works
on HP.
moving to M15.  If we have time after getting the 
comercial builds running we will look into these.
Target Milestone: M14 → M15
Summary: M12 bugs to look for.... → Cut and Paste Problem
I'm pretty sure these are all known issues covered in other active or fixed bug
reports.
QA Contact: leger → elig
Reassigning to John
Assignee: pepper → jgaunt
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
pushing out to M17 ; changing QA ; removing shane from the Cc:
QA Contact: elig → jgaunt
Target Milestone: M15 → M17
Cannot consistantly cut/paste from location bar, window's clipboard viewer 
reports object is in binary format and cannot be displayed.
Normal Linux/X11 left-click/middle-click cut/paste doesn't work in Mozilla as it
did in Netscape 4. Microsoft-style click/alt-C might work but that is a step
backwards. Abandoning in-platform consistancy for cross-platform consistancy
with inferior functionality is a terrible idea. Being able to easily use the
clipsheet is a major feature, maybe enough to keep me using Netscape 4 for work.
Normal Unix auto-copy-on-select is working as of a week ago (on Linux, at
least).  Andrew should probably pick up a more recent build.  Middle-mouse paste
has been working for months on Linux (and sometimes on windows boxes if you set
middlemouse.paste, but there seems to be a lot of variability in Windows mouse
drivers and not all of them actually send a middle-click event), so this might
be HP-UX specific, but if you can reproduce it on Linux, please describe how and
I'll track down the middle-mouse problem (I would probably own that part of the
bug, but I don't have an HP-UX box to test on).  Linux does have problems with
the keyboard accelerators in some dialogs; there's a bug on that somewhere but
I've lost track of who owns it this week.  Lophat sounds like he's reporting a
problem in the windows clipboard code, which would be a different issue from
anything seen on HP-UX.
No evidence of problems on 11.00 closing this bug. If we still have trouble with 
10.20 we can open a new bug.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
tested - looks good
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.