Can't import Outlook mail if any folder name contains a slash

RESOLVED DUPLICATE of bug 131013

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 131013
15 years ago
10 years ago

People

(Reporter: Eric Scouten, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Thunderbird 0.2a (20030813)

If any folder in an Outlook (not Express) .pst file contains a slash in the 
name, Thunderbird will fail to import the entire collection of mail. (It may 
import some messages.) It will take several minutes before failing on a 
condition that should be easily detectable early on.

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird.
2. Choose Tools > Import, Mail, Outlook

Actual Results:  
After several minutes with the progress bar updating (properly), Thunderbird 
complains that it cannot import mail. I forget the exact message, but it boils 
down to one of the folders having a slash in the name.

Expected Results:  
Thunderbird should make a quick pass over the Outlook folders scanning for 
invalid names before spending time importing messages. If any bad names are 
found, it should fail immediately.

Comment 1

15 years ago
This is also happening with mail from Outlook Express
(although i'm using tb0.1)

maybe this is to be marked duplicate of
http://bugzilla.mozilla.org/show_bug.cgi?id=131013
(Reporter)

Comment 2

15 years ago
I agree this bug is basically the same as 131013. The main difference between 
the two (probably not worth maintaining two bug reports): My main complaint is 
that it takes several minutes to fail when the detection could be made very 
early in the import process.

Marking as duplicate.

*** This bug has been marked as a duplicate of 131013 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
URL: n/a
You need to log in before you can comment on or make changes to this bug.