prominent warning before making Moz/FB the default browser

RESOLVED DUPLICATE of bug 216501

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 216501
15 years ago
12 years ago

People

(Reporter: Ed Hume, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030816 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030816 Mozilla Firebird/0.6.1+

Most new Mozilla and Firebird users are not aware of the consequences of making
a non-IE browser the default browser in windows. They are generally not prepared
to see all the internet-related icons replaced with another icon. An ugly
surprise. It even happened to Jerry Pournelle when he tried Moz 1.0. It happened
to me, as well, gbefore I decided to make FB my default browser (a happy choice).

Actually, this danger is present in Moz and FB now, even if no installer is
used. If you click on that Set Firebird as your default browser checkbox, your
icons are changed. If your company has set up custom icons for certain file
types, those will be gone (this happened to a user); simply uninstalling FB will
not get those associations and icons back.

I propose that any time a user has an opportunity to select Moz or FB as default
browser, there should be a warning screen interposed before the action is
executed. This screen should warn the user that all internet-associated files
will be handled by Moz/FB, and will have that icon. Perhaps pictures of Windows
icons should be shown to make clear just what files will be changed.

Some users have noted that file associations for some graphics are changed when
Moz is installed. This can be an unpleasant surprise (most naive users won't
know where to look to be able to reverse those changes). This should probably
not be a feature of installation programs.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
bug 131106 and bug 214054 are also related to this

*** This bug has been marked as a duplicate of 216501 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.