Mozilla crashing (access violation) on nsGenericElement::HandleDOMEvent

VERIFIED INVALID

Status

()

Core
Event Handling
P3
critical
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: ckritzer (gone), Assigned: joki (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview Description: Build crashes on nsGenericElement::HandleDOMEvent when
running browser buster (apparently happens on chofmann's new browserbuster
random site list link)

Steps to Reproduce:
1) Launch build
2) Select Debug:chofmann's browser buster menu item
3) Click on 'random site list' link

Actual Results: mozilla crashed on nsGenericElement::HandleDOMEvent 50ef459

Expected Results: Run the browser buster random links test

Build Date & Platform Bug Found: WinNT 19991009

Additional Builds and Platforms Tested On: None.

Additional Information: All information taken from talkback report incident ID:
2226735, report generated by chofmann.

Running through "Steps to reproduce" on today's (1999121308) build
(Reporter)

Updated

18 years ago
QA Contact: janc → ckritzer
(Reporter)

Comment 1

18 years ago
Re-setting self to qacontact & cc'ing janc...
(Reporter)

Comment 2

18 years ago
Stack trace from Talkback incident ID#2226735:

 Call Stack:    (Signature = nsGenericElement::HandleDOMEvent 50e7f459)
  nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\base\src\nsGenericElement.cpp, line 775]

  nsHTMLAnchorElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLAnchorElement.cpp,
line 344]

  nsEventStateManager::SendFocusBlur
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
1936]

  nsEventStateManager::ChangeFocus
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
1433]

  nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
552]

  PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2581]

  nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 841]

  nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 826]

  nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 826]

  nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1678]

  HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]

  nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 425]

  nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 442]

  nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3334]

  ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3550]

  nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2646]

  nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 609]

  KERNEL32.DLL + 0x35d9 (0xbff735d9)
  KERNEL32.DLL + 0x2222f (0xbff9222f)
  0x00638c40

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
I am going to mark this invalid because without the knowing what page it crashed
on, I can't duplicate the error. I have running the browser buster for a while
and I have not seen it.You can reopen this bug if you can provide me with a
reproducable test case - rods
(Reporter)

Comment 4

18 years ago
Marking VERIFED INVALID on:
- Linux6 2000-02-01-10 Commercial build
- Win98 2000-02-01-08 Commercial build
- MacOS86 2000-02-01-09 Commercial build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.