Closed Bug 216432 Opened 17 years ago Closed 16 years ago

Firefox shouldn't steal so many file associations

Categories

(Firefox :: Preferences, defect, P3, minor)

x86
Windows XP
defect

Tracking

()

RESOLVED FIXED
Firefox0.9

People

(Reporter: SkewerMZ, Assigned: bugzilla)

References

Details

Noticed behavior with latest nightly, clean profile, clean system. Firebird
grabs the MNG association but cannot display MNG images due to bug 18574.
right, we don't support MNG and are unlikely to in the near future.  Also occurs
in Moz still.

-> taking, will worry about this when 1.0 approaches or MNG gets resolved
somehow (my money's on the former)
Assignee: blake → mpconnor
Component: General → Preferences
Depends on: 206618
QA Contact: asa
Severity: normal → minor
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Firebird0.8
Depends on: 216501
Depends on: 225791
Blocks: 225791
No longer depends on: 225791
Target Milestone: Firebird0.8 → Firebird0.9
Reassigning per 225791. 

What needs to be done here is that Firebird needs to not steal MNG, or any image
format really, as no decent platform ships today without a fast internal image
viewer that's generally always better than a web browser. The Windows picture
viewer for instance includes a zoom function. Stealing the association is a
usability loss. 

The best fix here will isolate the extensions that we want to associate with
(probably just html and xhtml, not sure about XUL) and only take those types.
Assignee: mpconnor → blake
Status: ASSIGNED → NEW
Depends on: 230921
Depends on: 230922
No longer depends on: 216501
Summary: Firebird takes the MNG association even though it isn't capable of displaying MNG → Firefox takes the MNG association even though it isn't capable of displaying MNG
*** Bug 234388 has been marked as a duplicate of this bug. ***
Summary: Firefox takes the MNG association even though it isn't capable of displaying MNG → Firefox shouldn't steal so many file associations
Fixed.  Also fixed Firefox to not steal the "edit" association for html files.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
*** Bug 230922 has been marked as a duplicate of this bug. ***
*** Bug 234650 has been marked as a duplicate of this bug. ***
I don't know what your fix includes but if it also stops firefox from claiming
the .hta extension for itself then that would be great!
I don't see .hta in nsWIndowsHooks.cpp before nor after the patch.
*** Bug 236421 has been marked as a duplicate of this bug. ***
*** Bug 241248 has been marked as a duplicate of this bug. ***
*** Bug 228173 has been marked as a duplicate of this bug. ***
No longer depends on: 230922
I just installed Firefox 0.9.3 on a Windows XP computer that had the image
associations associated with Firefox 0.8.x and Firefox WASN'T set to the default
browser anymore. The image associations weren't automatically changed back, and
when I later associated MS's image viewer as the program that should open these
types in the menu, but the icons for the image files aren't changed back to the
default. Firefox should detect image files being associated with Firefox and set
them back. I am wondering if some logic that only does this if Firefox is set to
the default browser (which it wasn't upon first run) is causing this issue.
I don't agree with the previous comment. I think, since this change was pre-1.0,
it should be written off as an unfortunate problem for a few users. I think
putting code in to check for what were minor issues here would just be
unnecessary bloat and would probably invite more bugs.
You need to log in before you can comment on or make changes to this bug.