Double-clicking "close tab" button opens a new tab

VERIFIED FIXED

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
15 years ago
12 years ago

People

(Reporter: Fedde Hettinga, Assigned: David Hyatt)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030817 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030817 Mozilla Firebird/0.6.1+

Rapidly clicking the 'X' close button to close a number of tabs, serves as a
double-click on the tab-bar as well, and thus opens a new tab for every 2 clicks.

Reproducible: Always

Steps to Reproduce:
1. Open 3 (or more) tabs
2. Rapidly click the close button twice, to close 2 out of 3 tabs

Actual Results:  
After the 2 rapid clicks, the 2 tabs are closed, but an extra tab appears.

Expected Results:  
Just closed 2 tabs, not create a new extra tab. There should only be 1 tab in
the end (that is, when you try this with 3 tabs).

Happens with every theme. The solution is to exclude the 'X' from the
"tab-bar-double-click-region".

Comment 1

15 years ago
Confirmed (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b)
Gecko/20030817 Mozilla Firebird/0.6.1+)

Additional thoughts: I find that the double click tab bar thing is annoying when
you have as many tabs open as I do (10-20 usually, when I'm surfing forums).
I suggest that a new pref (in user.js or maybe in advanced if there is space) is
added so that if , 5 prefs (this would be made default) are opened double
clicking does not open a new tab. This is mainly because I middle click on tabs
too close them, and if I miss and by accident click on the space above I often
get a new tab.

Comment 2

15 years ago
I also see this on Linux FireBird 20030817.

A fix for bug 187199 would solve this bug, but it doesn't look like such a fix
is likely.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 3

15 years ago
*** Bug 217122 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
noririty, can you take a look at this? Seems to be an easy fix proposed in the
bug report.

Comment 5

15 years ago
From bug 217122 (duped against this one):

b) Alternate click (first left-click then right-click) on close tab button - 
   Closes one tab and opens one new one
c) Alternate click on tab bar (empty space) - Opens new tab

Alternate click doesn't count as double click, therefore, it shouldn't open a
new tab when used in the tab bar. The behaviour on the close tab button should
also be fixed so that opening a new tab doesn't function there.

Changing summary to reflect this. It seems that this is not so simple to fix.
Assignee: blake → hyatt
Component: General → Toolbars
QA Contact: asa → bugzilla
Summary: Rapidly closing tabs with the 'X' close button, spawns new tabs → Double-clicking/Alternate left-right-clicking on close tab button/tab bar opens new tab

Comment 6

15 years ago
I suspect this related to bug 213228(just guessing, though).

Updated

15 years ago
Keywords: regression

Comment 7

15 years ago
Simon: the stuff involving right-clicks is bug 217560.
Summary: Double-clicking/Alternate left-right-clicking on close tab button/tab bar opens new tab → Double-clicking "close tab" button opens a new tab

Comment 8

15 years ago
This regression was caused by the following checkin:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Ftoolkit%2Fcontent%2Fwidgets%2F&file=tabbox.xml&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=08%2F16%2F2003&maxdate=08%2F18%2F2003&cvsroot=%2Fcvsroot

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/toolkit/content/widgets&command=DIFF_FRAMESET&file=tabbox.xml&rev1=1.6&rev2=1.7&root=/cvsroot

As part of that checkin to tabbox.xml, pch changed
          <xul:toolbarbutton ondblclick="event.preventBubble();"
class="tabs-closebutton close-button"
xbl:inherits="disabled=disableclose,oncommand=onclosetab"/>

to
          <xul:toolbarbutton class="tabs-closebutton close-button"
xbl:inherits="disabled=disableclose,oncommand=onclosetab"/>

I don't know why pch changed that line.  None of the bugs he references in the
checkin comment change that line.  Maybe he copied the entire file from
Seamonkey, missing all changes that had been made to the file since Firebird
forked it?

Comment 9

15 years ago
Created attachment 130516 [details] [diff] [review]
patch to revert the line (re-add ondblclick)

Comment 10

15 years ago
cc'ing pch since this patch reverts a change he made.

Comment 12

15 years ago
noririty checked in my fix (or an identical fix based on his last comment) at
09/01/2003 11:47.  And this bug is fixed in today's Firebird build :)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
verified fixed 2003-11-09
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.