[Mac] Preferences dialog should not be modal

RESOLVED DUPLICATE of bug 206651

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 206651
15 years ago
12 years ago

People

(Reporter: Kevin Gerich, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030806 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030806 Mozilla Firebird/0.6.1+

The preferences dialog is rendered as a sheet. The dialog is not document-modal
so it should not be rendered as a sheet.

From the AHIG: When Not to Use Sheets

    * Don’t use sheets for dialogs that apply to several windows. Sheets are
strictly intended to be used in situations when a particular dialog is
associated only with the window to which it is attached.

    * Sheets are not appropriate for modeless operations where the dialog should
be left open to allow the user to observe the effects of changes applied. Such
tasks (find and replace operations, for example) are better suited to modeless
dialogs, utility windows (palettes), or drawers.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

*** This bug has been marked as a duplicate of 206651 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.